Skip to content

Commit

Permalink
Merge remote-tracking branch 'op/main'
Browse files Browse the repository at this point in the history
  • Loading branch information
breeze303 committed Sep 27, 2024
2 parents d3e6c5a + a4c95f1 commit 22e0235
Show file tree
Hide file tree
Showing 74 changed files with 1,276 additions and 3,132 deletions.
11 changes: 11 additions & 0 deletions package/kernel/ath10k-ct/patches/010-api_update.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
--- a/ath10k-6.9/mac.c
+++ b/ath10k-6.9/mac.c
@@ -6238,7 +6238,7 @@ err:
return ret;
}

-static void ath10k_stop(struct ieee80211_hw *hw)
+static void ath10k_stop(struct ieee80211_hw *hw, bool suspend)
{
struct ath10k *ar = hw->priv;
u32 opt;
4 changes: 2 additions & 2 deletions package/kernel/mac80211/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -10,13 +10,13 @@ include $(INCLUDE_DIR)/kernel.mk

PKG_NAME:=mac80211

PKG_VERSION:=6.9.9
PKG_VERSION:=6.11
PKG_RELEASE:=1
PKG_LICENSE:=GPL-2.0-only
PKG_LICENSE_FILES:=COPYING

PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources/
PKG_HASH:=3417da091a57c7b1c145d44c1fae9f1e0bac6d0c8ad61b37e57b0a802eeb2837
PKG_HASH:=2c091ce9520c2e4c8a9c91a294f3c040f90cd76222674928e61542ead06cfa41

PKG_SOURCE:=backports-$(PKG_VERSION).tar.xz
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(if $(BUILD_VARIANT),$(PKG_NAME)-$(BUILD_VARIANT)/)backports-$(PKG_VERSION)
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -82,7 +82,7 @@
help
--- a/local-symbols
+++ b/local-symbols
@@ -94,6 +94,7 @@ ADM8211=
@@ -96,6 +96,7 @@ ADM8211=
ATH_COMMON=
WLAN_VENDOR_ATH=
ATH_DEBUG=
Expand Down
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- a/drivers/net/wireless/ath/ath10k/Kconfig
+++ b/drivers/net/wireless/ath/ath10k/Kconfig
@@ -88,6 +88,12 @@ config ATH10K_TRACING
@@ -94,6 +94,12 @@ config ATH10K_TRACING
help
Select this to ath10k use tracing infrastructure.

Expand All @@ -21,9 +21,9 @@
ath10k_core-$(CPTCFG_ATH10K_TRACING) += trace.o
-ath10k_core-$(CONFIG_THERMAL) += thermal.o
+ath10k_core-$(CPTCFG_ATH10K_THERMAL) += thermal.o
ath10k_core-$(CPTCFG_ATH10K_LEDS) += leds.o
ath10k_core-$(CPTCFG_MAC80211_DEBUGFS) += debugfs_sta.o
ath10k_core-$(CONFIG_PM) += wow.o
ath10k_core-$(CONFIG_DEV_COREDUMP) += coredump.o
--- a/drivers/net/wireless/ath/ath10k/thermal.h
+++ b/drivers/net/wireless/ath/ath10k/thermal.h
@@ -25,7 +25,7 @@ struct ath10k_thermal {
Expand All @@ -37,9 +37,9 @@
void ath10k_thermal_event_temperature(struct ath10k *ar, int temperature);
--- a/local-symbols
+++ b/local-symbols
@@ -153,6 +153,7 @@ ATH10K_SNOC=
ATH10K_DEBUG=
@@ -156,6 +156,7 @@ ATH10K_DEBUG=
ATH10K_DEBUGFS=
ATH10K_LEDS=
ATH10K_SPECTRAL=
+ATH10K_THERMAL=
ATH10K_TRACING=
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -14,7 +14,7 @@ Signed-off-by: Sven Eckelmann <sven@open-mesh.com>

--- a/drivers/net/wireless/ath/ath10k/core.c
+++ b/drivers/net/wireless/ath/ath10k/core.c
@@ -3527,6 +3527,16 @@ int ath10k_core_register(struct ath10k *
@@ -3539,6 +3539,16 @@ int ath10k_core_register(struct ath10k *

queue_work(ar->workqueue, &ar->register_work);

Expand Down
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- a/drivers/net/wireless/ath/ath10k/mac.c
+++ b/drivers/net/wireless/ath/ath10k/mac.c
@@ -9918,6 +9918,21 @@ static int ath10k_mac_init_rd(struct ath
@@ -9919,6 +9919,21 @@ static int ath10k_mac_init_rd(struct ath
return 0;
}

Expand All @@ -22,7 +22,7 @@
int ath10k_mac_register(struct ath10k *ar)
{
static const u32 cipher_suites[] = {
@@ -10280,6 +10295,12 @@ int ath10k_mac_register(struct ath10k *a
@@ -10281,6 +10296,12 @@ int ath10k_mac_register(struct ath10k *a

ar->hw->weight_multiplier = ATH10K_AIRTIME_WEIGHT_MULTIPLIER;

Expand Down
Loading

0 comments on commit 22e0235

Please sign in to comment.