Skip to content

Commit

Permalink
Merge remote-tracking branch 'op/main'
Browse files Browse the repository at this point in the history
  • Loading branch information
breeze303 committed Apr 17, 2024
2 parents a333578 + 9cef2bc commit c076413
Show file tree
Hide file tree
Showing 47 changed files with 686 additions and 158 deletions.
4 changes: 2 additions & 2 deletions include/kernel-5.15
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
LINUX_VERSION-5.15 = .153
LINUX_KERNEL_HASH-5.15.153 = d7ddb1e144a88773b56a5b4a71baea0b241f3996d446be45290537c6997c84bc
LINUX_VERSION-5.15 = .155
LINUX_KERNEL_HASH-5.15.155 = c85859b86d2e6d1fc91ca1be8b44f24a9b5bb9f86869b04a8665a3a6559126e4
10 changes: 6 additions & 4 deletions package/firmware/ipq-wifi/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,13 +2,13 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/version.mk

PKG_NAME:=ipq-wifi
PKG_RELEASE:=2
PKG_RELEASE:=1

PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/project/firmware/qca-wireless.git
PKG_SOURCE_DATE:=2024-03-20
PKG_SOURCE_VERSION:=87717baa8a7c922942f4202a0ec3de3cb5643941
PKG_MIRROR_HASH:=a88124db0cd9a386d2cbd905e48408e7131f057240bcc7da93f7c5fc10ea4892
PKG_SOURCE_DATE:=2024-04-16
PKG_SOURCE_VERSION:=1d51799e6768a304da7840b8346e7487efd77f49
PKG_MIRROR_HASH:=9cf0917532283c1a1708643022a5ed1ec4af6bb9ebaff57fc2f0f2c229f2469e
PKG_FLAGS:=nonshared

include $(INCLUDE_DIR)/package.mk
Expand Down Expand Up @@ -61,6 +61,7 @@ ALLWIFIBOARDS:= \
yuncore_ax880 \
zn_m2 \
yuncore_fap650 \
zbtlink_zbt-z800ax \
zte_mf269 \
zte_mf287 \
zte_mf287plus \
Expand Down Expand Up @@ -188,6 +189,7 @@ $(eval $(call generate-ipq-wifi-package,yyets_le1,YYeTs LE1))
$(eval $(call generate-ipq-wifi-package,yuncore_ax880,Yuncore AX880))
$(eval $(call generate-ipq-wifi-package,zn_m2,ZN M2))
$(eval $(call generate-ipq-wifi-package,yuncore_fap650,Yuncore FAP650))
$(eval $(call generate-ipq-wifi-package,zbtlink_zbt-z800ax,Zbtlink ZBT-Z800AX))
$(eval $(call generate-ipq-wifi-package,zte_mf269,ZTE MF269))
$(eval $(call generate-ipq-wifi-package,zte_mf287,ZTE MF287))
$(eval $(call generate-ipq-wifi-package,zte_mf287plus,ZTE MF287Plus))
Expand Down
4 changes: 3 additions & 1 deletion package/network/utils/comgt/files/ncm.sh
Original file line number Diff line number Diff line change
Expand Up @@ -19,6 +19,7 @@ proto_ncm_init_config() {
proto_config_add_string delay
proto_config_add_string mode
proto_config_add_string pdptype
proto_config_add_boolean sourcefilter
proto_config_add_int profile
proto_config_add_defaults
}
Expand All @@ -29,7 +30,7 @@ proto_ncm_setup() {
local manufacturer initialize setmode connect finalize devname devpath ifpath

local device ifname apn auth username password pincode delay mode pdptype profile $PROTO_DEFAULT_OPTIONS
json_get_vars device ifname apn auth username password pincode delay mode pdptype profile $PROTO_DEFAULT_OPTIONS
json_get_vars device ifname apn auth username password pincode delay mode pdptype sourcefilter profile $PROTO_DEFAULT_OPTIONS

local context_type

Expand Down Expand Up @@ -202,6 +203,7 @@ proto_ncm_setup() {
json_add_string ifname "@$interface"
json_add_string proto "dhcpv6"
json_add_string extendprefix 1
[ "$sourcefilter" = "0" ] && json_add_boolean sourcefilter "0"
proto_add_dynamic_defaults
[ -n "$zone" ] && {
json_add_string zone "$zone"
Expand Down
4 changes: 2 additions & 2 deletions package/network/utils/ipset/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk

PKG_NAME:=ipset
PKG_VERSION:=7.17
PKG_VERSION:=7.21
PKG_RELEASE:=1

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://ipset.netfilter.org
PKG_HASH:=be49c9ff489dd6610cad6541e743c3384eac96e9f24707da7b3929d8f2ac64d8
PKG_HASH:=e2c6ce4fcf3acb3893ca5d35c86935f80ad76fc5ccae601185842df760e0bc69

PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
PKG_LICENSE:=GPL-2.0
Expand Down
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
--- a/src/ipset.c
+++ b/src/ipset.c
@@ -6,8 +6,8 @@
* it under the terms of the GNU General Public License version 2 as
* published by the Free Software Foundation.
*/
-#define _GNU_SOURCE
#include <assert.h> /* assert */
+#include <libgen.h> /* basename */
#include <stdio.h> /* fprintf */
#include <stdlib.h> /* exit */
#include <string.h> /* strcmp */
4 changes: 3 additions & 1 deletion package/network/utils/umbim/files/lib/netifd/proto/mbim.sh
Original file line number Diff line number Diff line change
Expand Up @@ -22,6 +22,7 @@ proto_mbim_init_config() {
[ -e /proc/sys/net/ipv6 ] && proto_config_add_string ipv6
proto_config_add_string dhcp
proto_config_add_string dhcpv6
proto_config_add_boolean sourcefilter
proto_config_add_string pdptype
proto_config_add_int mtu
proto_config_add_defaults
Expand All @@ -47,7 +48,7 @@ _proto_mbim_setup() {
local device apn pincode delay auth username password allow_roaming allow_partner
local dhcp dhcpv6 pdptype ip4table ip6table mtu $PROTO_DEFAULT_OPTIONS
json_get_vars device apn pincode delay auth username password allow_roaming allow_partner
json_get_vars dhcp dhcpv6 pdptype ip4table ip6table mtu $PROTO_DEFAULT_OPTIONS
json_get_vars dhcp dhcpv6 sourcefilter pdptype ip4table ip6table mtu $PROTO_DEFAULT_OPTIONS

[ ! -e /proc/sys/net/ipv6 ] && ipv6=0 || json_get_var ipv6 ipv6

Expand Down Expand Up @@ -263,6 +264,7 @@ _proto_mbim_setup() {
echo "mbim[$$]" "Starting DHCPv6 on $ifname"
json_add_string proto "dhcpv6"
json_add_string extendprefix 1
[ "$sourcefilter" = "0" ] && json_add_boolean sourcefilter "0"
fi

[ "$peerdns" = 0 -a "$dhcpv6" != 1 ] || {
Expand Down
4 changes: 3 additions & 1 deletion package/network/utils/uqmi/files/lib/netifd/proto/qmi.sh
Original file line number Diff line number Diff line change
Expand Up @@ -23,6 +23,7 @@ proto_qmi_init_config() {
proto_config_add_int v6profile
proto_config_add_boolean dhcp
proto_config_add_boolean dhcpv6
proto_config_add_boolean sourcefilter
proto_config_add_boolean autoconnect
proto_config_add_int plmn
proto_config_add_int timeout
Expand All @@ -41,7 +42,7 @@ proto_qmi_setup() {
local profile_pdptype

json_get_vars device apn v6apn auth username password pincode delay modes
json_get_vars pdptype profile v6profile dhcp dhcpv6 autoconnect plmn ip4table
json_get_vars pdptype profile v6profile dhcp dhcpv6 sourcefilter autoconnect plmn ip4table
json_get_vars ip6table timeout mtu $PROTO_DEFAULT_OPTIONS

[ "$timeout" = "" ] && timeout="10"
Expand Down Expand Up @@ -441,6 +442,7 @@ proto_qmi_setup() {
proto_add_dynamic_defaults
# RFC 7278: Extend an IPv6 /64 Prefix to LAN
json_add_string extendprefix 1
[ "$sourcefilter" = "0" ] && json_add_boolean sourcefilter "0"
[ -n "$zone" ] && json_add_string zone "$zone"
json_close_object
ubus call network add_dynamic "$(json_dump)"
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -552,7 +552,7 @@ Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
--- a/kernel/bounds.c
+++ b/kernel/bounds.c
@@ -22,6 +22,11 @@ int main(void)
DEFINE(NR_CPUS_BITS, ilog2(CONFIG_NR_CPUS));
DEFINE(NR_CPUS_BITS, bits_per(CONFIG_NR_CPUS));
#endif
DEFINE(SPINLOCK_SIZE, sizeof(spinlock_t));
+#ifdef CONFIG_LRU_GEN
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -1251,7 +1251,7 @@ Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
get_scan_count(lruvec, sc, nr);

/* Record the original scan target for proportional adjustments later */
@@ -3372,6 +4142,9 @@ static void snapshot_refaults(struct mem
@@ -3375,6 +4145,9 @@ static void snapshot_refaults(struct mem
struct lruvec *target_lruvec;
unsigned long refaults;

Expand All @@ -1261,7 +1261,7 @@ Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
target_lruvec = mem_cgroup_lruvec(target_memcg, pgdat);
refaults = lruvec_page_state(target_lruvec, WORKINGSET_ACTIVATE_ANON);
target_lruvec->refaults[0] = refaults;
@@ -3736,12 +4509,16 @@ unsigned long try_to_free_mem_cgroup_pag
@@ -3739,12 +4512,16 @@ unsigned long try_to_free_mem_cgroup_pag
}
#endif

Expand All @@ -1280,7 +1280,7 @@ Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
if (!can_age_anon_pages(pgdat, sc))
return;

@@ -4058,12 +4835,11 @@ restart:
@@ -4061,12 +4838,11 @@ restart:
sc.may_swap = !nr_boost_reclaim;

/*
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -149,15 +149,15 @@ Signed-off-by: Andrew Morton <akpm@linux-foundation.org>

--- a/fs/exec.c
+++ b/fs/exec.c
@@ -1013,6 +1013,7 @@ static int exec_mmap(struct mm_struct *m
@@ -1014,6 +1014,7 @@ static int exec_mmap(struct mm_struct *m
active_mm = tsk->active_mm;
tsk->active_mm = mm;
tsk->mm = mm;
+ lru_gen_add_mm(mm);
/*
* This prevents preemption while active_mm is being loaded and
* it and mm are being updated, which could cause problems for
@@ -1028,6 +1029,7 @@ static int exec_mmap(struct mm_struct *m
@@ -1029,6 +1030,7 @@ static int exec_mmap(struct mm_struct *m
tsk->mm->vmacache_seqnum = 0;
vmacache_flush(tsk);
task_unlock(tsk);
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -31,15 +31,15 @@ Signed-off-by: Andrew Morton <akpm@linux-foundation.org>

--- a/fs/exec.c
+++ b/fs/exec.c
@@ -1013,7 +1013,6 @@ static int exec_mmap(struct mm_struct *m
@@ -1014,7 +1014,6 @@ static int exec_mmap(struct mm_struct *m
active_mm = tsk->active_mm;
tsk->active_mm = mm;
tsk->mm = mm;
- lru_gen_add_mm(mm);
/*
* This prevents preemption while active_mm is being loaded and
* it and mm are being updated, which could cause problems for
@@ -1028,6 +1027,7 @@ static int exec_mmap(struct mm_struct *m
@@ -1029,6 +1028,7 @@ static int exec_mmap(struct mm_struct *m
local_irq_enable();
tsk->mm->vmacache_seqnum = 0;
vmacache_flush(tsk);
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -354,7 +354,7 @@ Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
static void mem_cgroup_css_free(struct cgroup_subsys_state *css)
--- a/mm/page_alloc.c
+++ b/mm/page_alloc.c
@@ -7661,6 +7661,7 @@ static void __init free_area_init_node(i
@@ -7663,6 +7663,7 @@ static void __init free_area_init_node(i
pgdat_set_deferred_range(pgdat);

free_area_init_core(pgdat);
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -32,7 +32,7 @@ Signed-off-by: Jakub Kicinski <kuba@kernel.org>

--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -11783,6 +11783,14 @@ L: netdev@vger.kernel.org
@@ -11790,6 +11790,14 @@ L: netdev@vger.kernel.org
S: Maintained
F: drivers/net/ethernet/mediatek/

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -25,7 +25,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>

--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -11895,6 +11895,7 @@ M: Landen Chao <Landen.Chao@mediatek.com
@@ -11902,6 +11902,7 @@ M: Landen Chao <Landen.Chao@mediatek.com
M: DENG Qingfang <dqfext@gmail.com>
L: netdev@vger.kernel.org
S: Maintained
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -28,7 +28,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>

--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -11893,9 +11893,11 @@ MEDIATEK SWITCH DRIVER
@@ -11900,9 +11900,11 @@ MEDIATEK SWITCH DRIVER
M: Sean Wang <sean.wang@mediatek.com>
M: Landen Chao <Landen.Chao@mediatek.com>
M: DENG Qingfang <dqfext@gmail.com>
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -21,7 +21,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>

--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -12694,6 +12694,7 @@ F: include/uapi/linux/meye.h
@@ -12701,6 +12701,7 @@ F: include/uapi/linux/meye.h

MOTORCOMM PHY DRIVER
M: Peter Geis <pgwipeout@gmail.com>
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -19,7 +19,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>

--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -17959,6 +17959,11 @@ L: netdev@vger.kernel.org
@@ -17966,6 +17966,11 @@ L: netdev@vger.kernel.org
S: Maintained
F: drivers/net/ethernet/dlink/sundance.c

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -57,7 +57,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>

--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -12358,6 +12358,14 @@ S: Supported
@@ -12365,6 +12365,14 @@ S: Supported
F: Documentation/devicetree/bindings/mtd/atmel-nand.txt
F: drivers/mtd/nand/raw/atmel/*

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -132,7 +132,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
imx_ocotp_nvmem_config.priv = priv;
--- a/drivers/nvmem/meson-efuse.c
+++ b/drivers/nvmem/meson-efuse.c
@@ -93,6 +93,7 @@ static int meson_efuse_probe(struct plat
@@ -74,6 +74,7 @@ static int meson_efuse_probe(struct plat

econfig->dev = dev;
econfig->name = dev_name(dev);
Expand Down
1 change: 1 addition & 0 deletions target/linux/generic/config-5.15
Original file line number Diff line number Diff line change
Expand Up @@ -4260,6 +4260,7 @@ CONFIG_NEW_LEDS=y
# CONFIG_NFC is not set
# CONFIG_NFP is not set
# CONFIG_NFSD is not set
# CONFIG_NFSD_V2 is not set
# CONFIG_NFSD_V2_ACL is not set
CONFIG_NFSD_V3=y
# CONFIG_NFSD_V3_ACL is not set
Expand Down
4 changes: 2 additions & 2 deletions target/linux/generic/hack-5.15/221-module_exports.patch
Original file line number Diff line number Diff line change
Expand Up @@ -27,8 +27,8 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
+#define SYMTAB_DISCARD_GPL
+#endif
+
/* Align . to a 8 byte boundary equals to maximum function alignment. */
#define ALIGN_FUNCTION() . = ALIGN(8)
/* Align . function alignment. */
#define ALIGN_FUNCTION() . = ALIGN(CONFIG_FUNCTION_ALIGNMENT)

@@ -485,14 +495,14 @@
/* Kernel symbol table: Normal symbols */ \
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -43,7 +43,7 @@ Subject: [PATCH] net/usb/qmi_wwan: add MeigLink modem support

#define QUECTEL_VENDOR_ID 0x2c7c
/* These Quectel products use Quectel's vendor ID */
@@ -1147,6 +1152,11 @@ static const struct usb_device_id option
@@ -1152,6 +1157,11 @@ static const struct usb_device_id option
{ USB_DEVICE(QUALCOMM_VENDOR_ID, 0x0023)}, /* ONYX 3G device */
{ USB_DEVICE(QUALCOMM_VENDOR_ID, 0x9000), /* SIMCom SIM5218 */
.driver_info = NCTRL(0) | NCTRL(1) | NCTRL(2) | NCTRL(3) | RSVD(4) },
Expand All @@ -55,7 +55,7 @@ Subject: [PATCH] net/usb/qmi_wwan: add MeigLink modem support
/* Quectel products using Qualcomm vendor ID */
{ USB_DEVICE(QUALCOMM_VENDOR_ID, QUECTEL_PRODUCT_UC15)},
{ USB_DEVICE(QUALCOMM_VENDOR_ID, QUECTEL_PRODUCT_UC20),
@@ -1188,6 +1198,11 @@ static const struct usb_device_id option
@@ -1193,6 +1203,11 @@ static const struct usb_device_id option
.driver_info = ZLP },
{ USB_DEVICE(QUECTEL_VENDOR_ID, QUECTEL_PRODUCT_BG96),
.driver_info = RSVD(4) },
Expand Down
2 changes: 1 addition & 1 deletion target/linux/generic/hack-5.15/902-debloat_proc.patch
Original file line number Diff line number Diff line change
Expand Up @@ -29,7 +29,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>

--- a/fs/locks.c
+++ b/fs/locks.c
@@ -2953,6 +2953,8 @@ static const struct seq_operations locks
@@ -3008,6 +3008,8 @@ static const struct seq_operations locks

static int __init proc_locks_init(void)
{
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -19,7 +19,7 @@ Signed-off-by: Rafał Miłecki <rafal@milecki.pl>

--- a/drivers/base/core.c
+++ b/drivers/base/core.c
@@ -1562,7 +1562,7 @@ static void device_links_purge(struct de
@@ -1577,7 +1577,7 @@ static void device_links_purge(struct de
#define FW_DEVLINK_FLAGS_RPM (FW_DEVLINK_FLAGS_ON | \
DL_FLAG_PM_RUNTIME)

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -71,7 +71,7 @@ Signed-off-by: Tobias Wolf <dev-NTEO@vplace.de>

--- a/mm/page_alloc.c
+++ b/mm/page_alloc.c
@@ -7620,7 +7620,7 @@ static void __init alloc_node_mem_map(st
@@ -7622,7 +7622,7 @@ static void __init alloc_node_mem_map(st
if (pgdat == NODE_DATA(0)) {
mem_map = NODE_DATA(0)->node_mem_map;
if (page_to_pfn(mem_map) != pgdat->node_start_pfn)
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -91,7 +91,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
for (i = sizeof(struct ipt_entry);
i < e->target_offset;
i += m->u.match_size) {
@@ -1222,12 +1259,15 @@ compat_copy_entry_to_user(struct ipt_ent
@@ -1224,12 +1261,15 @@ compat_copy_entry_to_user(struct ipt_ent
compat_uint_t origsize;
const struct xt_entry_match *ematch;
int ret = 0;
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -18,7 +18,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>

--- a/net/netfilter/nf_tables_api.c
+++ b/net/netfilter/nf_tables_api.c
@@ -7770,7 +7770,7 @@ static int nft_register_flowtable_net_ho
@@ -7803,7 +7803,7 @@ static int nft_register_flowtable_net_ho
err = flowtable->data.type->setup(&flowtable->data,
hook->ops.dev,
FLOW_BLOCK_BIND);
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -17,7 +17,7 @@ Signed-off-by: Alexander Duyck <alexanderduyck@fb.com>

--- a/net/core/skbuff.c
+++ b/net/core/skbuff.c
@@ -4359,6 +4359,15 @@ int skb_gro_receive(struct sk_buff *p, s
@@ -4360,6 +4360,15 @@ int skb_gro_receive(struct sk_buff *p, s
if (unlikely(p->len + len >= 65536 || NAPI_GRO_CB(skb)->flush))
return -E2BIG;

Expand Down
Loading

0 comments on commit c076413

Please sign in to comment.