Skip to content

Commit

Permalink
(graphics/R-scales) Updated 1.2.1 to 1.3.0
Browse files Browse the repository at this point in the history
# scales 1.3.0

## Better type support
* `rescale(I(x), ...)` and `rescale_mid(I(x), ...)` return `I(x)` unaltered
  (@teunbrand, #403).
* Add a rescale method for `difftime` objects (#382)
* Add better support for `difftime` objects. `label_timespan()` adds
  functionality for adding correct unit suffix to timespan data,
  `breaks_timespan()` adds functionality for finding pleasant breakpoints across
  the various bases in time units, while `transform_timespan()` wraps it all
  together and provides an alternative to `transform_hms()` (#212)

## Ranges
* `train_continuous()` coerces `new` to numeric before calculating range
  (@teunbrand, #369).
* Training on factor data no longer sorts the range after multiple training
  passes if the new `fct` argument of `train_discrete()` is used (#383)
* The `DiscreteRange` class now keeps track on whether it has been trained on
  factor data.
* Attempt to make the sort behavior of the range consistent for character
  vectors during training. Mixing of character and factor data will make the
  factor level order take precedence no matter if the training starts with a
  charactor vector

## Transformations
* Transformation function have been renamed to `transform_*`-prefixed names
  instead of `*_trans`-suffixed names. This allows for a better tab-completion
  search of transformations. The S3 class of transformations has been
  renamed from `"trans"` to `"transform"`. `new_transform()` replaces
  `trans_new()` and `trim_to_domain()` replaces `trans_range()`. All old
  functions are kept for posterity.
* `transform_sqrt()` no longer returns an inverse for values outside of its
  domain (#214)
* Add an inverse (area) hyperbolic sine transformation `transform_asinh()`,
  which provides a logarithm-like transformation of a space, but which
  accommodates negative values (#297)
* Correct the domain calculation for `transform_compose()` (@mjskay, #408).
* Transformation objects can optionally include the derivatives of the transform
  and the inverse transform (@mjskay, #322).

## Misc
* The `scale_cut` argument in `number()` now works as advertised for values
  below the lowest cut value (#346)
* `scale_cut` will now choose a more appropriate cut in the case of the first
  cut creating an irrational-ish number.
* Added a new option to the `style_positive` argument in `label_*()` functions.
  Setting this to `"space"` will add a figure space in front of the number to
  make it easier to align positive and negative values as figure space takes up
  the same amount of space as `-` (#366)
* `label_dollar()` has been superseeded by `label_currency()` for clarity (#344)
* Palette functions now have the `pal_`-prefix. The old `_pal`-suffixed versions
  are kept for backward compatibility.
  • Loading branch information
mef committed Jun 5, 2024
1 parent f76a5a8 commit 05317c0
Show file tree
Hide file tree
Showing 2 changed files with 6 additions and 6 deletions.
4 changes: 2 additions & 2 deletions graphics/R-scales/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.7 2023/06/11 11:23:31 mef Exp $
# $NetBSD: Makefile,v 1.8 2024/06/05 11:56:12 mef Exp $

R_PKGNAME= scales
R_PKGVER= 1.2.1
R_PKGVER= 1.3.0
CATEGORIES= graphics

MAINTAINER= minskim@NetBSD.org
Expand Down
8 changes: 4 additions & 4 deletions graphics/R-scales/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.7 2023/06/11 11:23:31 mef Exp $
$NetBSD: distinfo,v 1.8 2024/06/05 11:56:12 mef Exp $

BLAKE2s (R/scales_1.2.1.tar.gz) = 504ea76a1e0935d8ee12df9c648327bf5c5f8f6fbdda35774bc7085c3afeddef
SHA512 (R/scales_1.2.1.tar.gz) = fdac134485ce7fc63630ee087b4bb1a3580cd511ca3ae82a0548d9a08295384198fe2994cf8aef3fe6c8aedc1939bc87fce9deeaf898ccd89ea232712800dcc0
Size (R/scales_1.2.1.tar.gz) = 270609 bytes
BLAKE2s (R/scales_1.3.0.tar.gz) = fb17d4e29424f33c766b3e7e791abae14e90714b8f42309038d5f8ad0404b14e
SHA512 (R/scales_1.3.0.tar.gz) = cd5910ac1cc91d7f181eb2526024730a15dd3912cb2518d19426c2c8b95982e4bc473713ee09d90bf4be738e240f26df4d26608a53ae1dd09c4959118050d6a6
Size (R/scales_1.3.0.tar.gz) = 302544 bytes

0 comments on commit 05317c0

Please sign in to comment.