Skip to content

Commit

Permalink
py-sphinx-autoapi: update to 2.1.0.
Browse files Browse the repository at this point in the history
v2.1.0 (2023-03-28)
-------------------

Deprecations and Removals
^^^^^^^^^^^^^^^^^^^^^^^^^

- Support for documenting languages other than Python is deprecated. (#248)
- Removed the option to have autoapi generate toctree entries for domain objects.
  Domain objects are now added to the toctree by Sphinx.
  Dropped support for sphinx < 5.2.0. (#369)


Misc
^^^^

- Added basic type checking.
- Integrated towncrier into the release workflow.


v2.0.1 (2023-01-16)
-------------------

Features
^^^^^^^^
- Can turn off the addition of documented objects to the TOC tree.
- Added support for Python 3.11.

Bug Fixes
^^^^^^^^^
- `#330 <https://github.com/readthedocs/sphinx-autoapi/issues/330>`: (Python)
  Render tuple values as tuples, not lists.
- `#341 <https://github.com/readthedocs/sphinx-autoapi/issues/341>`: (Python)
  Fix module level assignments to class attributes being documented as
  module level attributes.
- (Python) Fix "bysource" sort order showing items in alphabetical order.
- (Python) Use the correct directives for a variable type and value.

Trivial/Internal Changes
^^^^^^^^^^^^^^^^^^^^^^^^
- Removed some autogenerated test data from the repository.


v2.0.0 (2022-09-27)
-------------------

Breaking Changes
^^^^^^^^^^^^^^^^

- Dropped support for Sphinx <4.
- `#352 <https://github.com/readthedocs/sphinx-autoapi/issues/352>`: (Python)
  Properties are rendered with the ``property`` directive,
  fixing support for Sphinx 5.2.
  A new ``PythonPythonMapper`` object (``PythonProperty``) has been created
  to support this change. This object can be passed to templates, filters,
  and hooks.
  A new ``property.rst`` template has also been created to support this change.

Trivial/Internal Changes
^^^^^^^^^^^^^^^^^^^^^^^^
- Use https links where possible in documentation.
- Pass correct argument types to ``status_iterator``.


V1.9.0 (2022-07-25)
-------------------

Breaking Changes
^^^^^^^^^^^^^^^^

- Dropped support for Python 3.6.

Features
^^^^^^^^

- Added support for Python 3.10.
- `#222 <https://github.com/readthedocs/sphinx-autoapi/issues/222>`:
  Marked extension as parallel read safe.

Bug Fixes
^^^^^^^^^
- `#324 <https://github.com/readthedocs/sphinx-autoapi/issues/324>`: (Python)
  Fail elegantly when no source files are found.
- (Python) Stop calling ``autodoc-process-docstring`` when docstring is empty.
  Works around sphinx-doc/sphinx#10701.
- `#318 <https://github.com/readthedocs/sphinx-autoapi/issues/318>`: (Python)
  Fixed misaligned argument types on methods/classmethods when using type comments.
- `#278 <https://github.com/readthedocs/sphinx-autoapi/issues/278>`: (Python)
  Limit signatures to 60 characters in summaries.
- Fix keyerror when using markdown sources.
- `#328 <https://github.com/readthedocs/sphinx-autoapi/issues/328>`: (Python)
  Fix kw-only marker getting ignored if first in the signature.

Trivial/Internal Changes
^^^^^^^^^^^^^^^^^^^^^^^^
- Fixed tests in Sphinx 5.
- Fixed many typos throughout the documentation.
  • Loading branch information
0-wiz-0 committed May 6, 2023
1 parent 98230b0 commit cadba75
Show file tree
Hide file tree
Showing 3 changed files with 16 additions and 18 deletions.
10 changes: 5 additions & 5 deletions textproc/py-sphinx-autoapi/Makefile
Original file line number Diff line number Diff line change
@@ -1,18 +1,17 @@
# $NetBSD: Makefile,v 1.8 2022/01/04 20:55:05 wiz Exp $
# $NetBSD: Makefile,v 1.9 2023/05/06 08:39:03 wiz Exp $

DISTNAME= sphinx-autoapi-1.8.4
DISTNAME= sphinx-autoapi-2.1.0
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
PKGREVISION= 1
CATEGORIES= textproc python
MASTER_SITES= ${MASTER_SITE_PYPI:=s/sphinx-autoapi/}

MAINTAINER= minskim@NetBSD.org
HOMEPAGE= https://github.com/readthedocs/sphinx-autoapi
COMMENT= Autodoc style documenation for multiple languages
COMMENT= Autodoc style documentation for multiple languages
LICENSE= mit

DEPENDS+= ${PYPKGPREFIX}-astroid>=2.7:../../devel/py-astroid
DEPENDS+= ${PYPKGPREFIX}-sphinx>=3.0:../../textproc/py-sphinx
DEPENDS+= ${PYPKGPREFIX}-sphinx>=5.2:../../textproc/py-sphinx
DEPENDS+= ${PYPKGPREFIX}-jinja2-[0-9]*:../../textproc/py-jinja2
DEPENDS+= ${PYPKGPREFIX}-yaml-[0-9]*:../../textproc/py-yaml
DEPENDS+= ${PYPKGPREFIX}-Unidecode-[0-9]*:../../textproc/py-Unidecode
Expand All @@ -23,6 +22,7 @@ USE_LANGUAGES= # none

PYTHON_VERSIONS_INCOMPATIBLE= 27

TEST_ENV+= PYTHONPATH=${WRKSRC}/build/lib
do-test:
cd ${WRKSRC} && ${SETENV} ${TEST_ENV} pytest-${PYVERSSUFFIX} tests

Expand Down
16 changes: 7 additions & 9 deletions textproc/py-sphinx-autoapi/PLIST
Original file line number Diff line number Diff line change
@@ -1,9 +1,4 @@
@comment $NetBSD: PLIST,v 1.3 2021/04/16 06:02:44 adam Exp $
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
${PYSITELIB}/${EGG_INFODIR}/requires.txt
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
@comment $NetBSD: PLIST,v 1.4 2023/05/06 08:39:03 wiz Exp $
${PYSITELIB}/autoapi/__init__.py
${PYSITELIB}/autoapi/__init__.pyc
${PYSITELIB}/autoapi/__init__.pyo
Expand Down Expand Up @@ -91,6 +86,9 @@ ${PYSITELIB}/autoapi/templates/python/function.rst
${PYSITELIB}/autoapi/templates/python/method.rst
${PYSITELIB}/autoapi/templates/python/module.rst
${PYSITELIB}/autoapi/templates/python/package.rst
${PYSITELIB}/autoapi/toctree.py
${PYSITELIB}/autoapi/toctree.pyc
${PYSITELIB}/autoapi/toctree.pyo
${PYSITELIB}/autoapi/templates/python/property.rst
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
${PYSITELIB}/${EGG_INFODIR}/requires.txt
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
8 changes: 4 additions & 4 deletions textproc/py-sphinx-autoapi/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.9 2021/10/26 11:23:13 nia Exp $
$NetBSD: distinfo,v 1.10 2023/05/06 08:39:03 wiz Exp $

BLAKE2s (sphinx-autoapi-1.8.4.tar.gz) = 6d1014c9a3ef77f6a003c6f87ca938db5c22ff130ff42a06d6954ffd9e682754
SHA512 (sphinx-autoapi-1.8.4.tar.gz) = 0ff2ab427c942d2f64d0f5c2986f9bf18cfc194824e194051232d34d15955d70f5c3f0e760e8765d39e98276ff4354ac705287dc1be2b8df40ecfe72a436087d
Size (sphinx-autoapi-1.8.4.tar.gz) = 42152704 bytes
BLAKE2s (sphinx-autoapi-2.1.0.tar.gz) = 51201fd7aa43751770207a2cc821b4b030c0fb76e6dcf8ca917f35042018a588
SHA512 (sphinx-autoapi-2.1.0.tar.gz) = 7d5fe4b52dc1071c0fcbbb316bfcf1b0a33c291834e50614e2ec6baf43bfb4938b27b9f39fca4d241b4624619e0a7623d85cdf1e7c5c531674cb895f839ac14b
Size (sphinx-autoapi-2.1.0.tar.gz) = 42158330 bytes

0 comments on commit cadba75

Please sign in to comment.