Skip to content

Commit

Permalink
chore(*): repository maintenance
Browse files Browse the repository at this point in the history
Moved lib to src. Fixed up gulp file with version bump. Added a
bower.json file. Added aurelia metadata to package.json. Updated the
readme with Used By libs.
  • Loading branch information
EisenbergEffect committed Dec 17, 2014
1 parent acf800b commit cb83b59
Show file tree
Hide file tree
Showing 7 changed files with 70 additions and 11 deletions.
5 changes: 5 additions & 0 deletions README.md
Original file line number Diff line number Diff line change
Expand Up @@ -8,6 +8,11 @@ This library is part of the [Aurelia](http://www.aurelia.io/) platform and conta

This library has **NO** external dependencies.

## Used By

* [aurelia-framework](https://github.com/aurelia/framework)
* [aurelia-templating](https://github.com/aurelia/templating)

## Platform Support

This library can be used in the **browser** as well as on the **server**.
Expand Down
16 changes: 16 additions & 0 deletions bower.json
Original file line number Diff line number Diff line change
@@ -0,0 +1,16 @@
{
"name": "aurelia-logging",
"version": "0.1.0",
"description": "A minimal but effective logging mechanism with support for log levels and pluggable log appenders.",
"keywords": [
"aurelia",
"logging"
],
"homepage": "http://aurelia.io",
"license": "MIT",
"authors": ["Rob Eisenberg <rob@bluespire.com> (http://robeisenberg.com/)"],
"repository": {
"type": "git",
"url": "http://github.com/aurelia/logging"
}
}
23 changes: 16 additions & 7 deletions gulpfile.js
Original file line number Diff line number Diff line change
Expand Up @@ -7,11 +7,11 @@ var stylish = require('jshint-stylish');
var yuidoc = require("gulp-yuidoc");
var changelog = require('conventional-changelog');
var assign = Object.assign || require('object.assign');
var pkg = require('./package.json');
var fs = require('fs');
var bump = require('gulp-bump');

var path = {
source:'lib/**/*.js',
source:'src/**/*.js',
output:'dist/',
doc:'./doc'
};
Expand Down Expand Up @@ -64,33 +64,42 @@ gulp.task('lint', function() {
});

gulp.task('doc', function(){
gulp.src(path.source)
return gulp.src(path.source)
.pipe(yuidoc.parser(null, 'api.json'))
.pipe(gulp.dest(path.doc));
});

gulp.task('bump-version', function(){
return gulp.src(['./bower.json', './package.json'])
.pipe(bump({type:'patch'})) //major|minor|patch|prerelease
.pipe(gulp.dest('./'));
});

gulp.task('changelog', function(callback) {
changelog({
var pkg = JSON.parse(fs.readFileSync('./package.json', 'utf-8'));

return changelog({
repository: pkg.repository.url,
version: pkg.version,
file: 'CHANGELOG.md'
file: path.doc + '/CHANGELOG.md'
}, function(err, log) {
fs.writeFileSync(path.doc + '/CHANGELOG.md', log);
});
});

gulp.task('build', function(callback) {
runSequence(
return runSequence(
'clean',
['build-es6', 'build-commonjs', 'build-amd'],
callback
);
});

gulp.task('prepare-release', function(callback){
runSequence(
return runSequence(
'build',
'lint',
'bump-version',
'doc',
'changelog',
callback
Expand Down
4 changes: 2 additions & 2 deletions karma.conf.js
Original file line number Diff line number Diff line change
Expand Up @@ -14,7 +14,7 @@ module.exports = function(config) {

jspm: {
// Edit this to your needs
loadFiles: ['lib/**/*.js', 'test/**/*.js']
loadFiles: ['src/**/*.js', 'test/**/*.js']
},


Expand All @@ -31,7 +31,7 @@ module.exports = function(config) {
// available preprocessors: https://npmjs.org/browse/keyword/karma-preprocessor
preprocessors: {
'test/**/*.js': ['6to5'],
'lib/**/*.js': ['6to5']
'src/**/*.js': ['6to5']
},


Expand Down
31 changes: 30 additions & 1 deletion package.json
Original file line number Diff line number Diff line change
Expand Up @@ -27,6 +27,7 @@
"conventional-changelog": "0.0.11",
"gulp": "^3.8.10",
"gulp-6to5": "^1.0.2",
"gulp-bump": "^0.1.11",
"gulp-clean": "^0.3.1",
"gulp-jshint": "^1.9.0",
"gulp-yuidoc": "^0.1.2",
Expand All @@ -39,5 +40,33 @@
"karma-jspm": "^1.0.1",
"object.assign": "^1.0.3",
"run-sequence": "^1.0.2"
},
"aurelia": {
"usedBy": [
"aurelia-framework",
"aurelia-templating"
],
"documentation": {
"links": [
{
"rel": "license",
"mediaType": "text/plain",
"title": "The MIT License (MIT)",
"href": "LICENSE"
},
{
"rel": "describedby",
"mediaType": "application/yuidoc+json",
"title": "API",
"href": "doc/api.json"
},
{
"rel": "version-history",
"mediaType": "text/markdown",
"title": "Change Log",
"href": "doc/CHANGELOG.md"
}
]
}
}
}
}
File renamed without changes.
2 changes: 1 addition & 1 deletion test/logging.spec.js
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
import * as LogManager from '../lib/index';
import * as LogManager from '../src/index';

describe('log manager', () => {
it('should have some tests', () => {
Expand Down

0 comments on commit cb83b59

Please sign in to comment.