Skip to content

Commit

Permalink
chore: release notes 3.3.0
Browse files Browse the repository at this point in the history
  • Loading branch information
aleksuss committed Oct 23, 2023
1 parent c82d1b7 commit 016dc72
Show file tree
Hide file tree
Showing 5 changed files with 10 additions and 8 deletions.
8 changes: 7 additions & 1 deletion CHANGES.md
Original file line number Diff line number Diff line change
Expand Up @@ -7,12 +7,17 @@ and this project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0

## [Unreleased]

## [3.3.0] 2023-10-23

### Changes

- Changed the logic of cost calculation in Silo mode. Specifically, the fixed cost has been replaced with
a fixed amount of gas per transaction by [@aleksuss]. ([#854])

- `near-workspaces-rs` has been updated to 0.8.0 by [@aleksuss]. ([#855])

[#854]: https://github.com/aurora-is-near/aurora-engine/pull/854
[#854]: https://github.com/aurora-is-near/aurora-engine/pull/855

## [3.2.0] 2023-10-17

Expand Down Expand Up @@ -533,7 +538,8 @@ struct SubmitResult {

## [1.0.0] - 2021-05-12

[Unreleased]: https://github.com/aurora-is-near/aurora-engine/compare/3.2.0...develop
[Unreleased]: https://github.com/aurora-is-near/aurora-engine/compare/3.3.0...develop
[3.3.0]: https://github.com/aurora-is-near/aurora-engine/compare/3.2.0...3.3.0
[3.2.0]: https://github.com/aurora-is-near/aurora-engine/compare/3.1.0...3.2.0
[3.1.0]: https://github.com/aurora-is-near/aurora-engine/compare/3.0.0...3.1.0
[3.0.0]: https://github.com/aurora-is-near/aurora-engine/compare/3.0.0...2.10.2
Expand Down
2 changes: 1 addition & 1 deletion Cargo.lock

Some generated files are not rendered by default. Learn more about how customized files appear on GitHub.

2 changes: 1 addition & 1 deletion VERSION
Original file line number Diff line number Diff line change
@@ -1 +1 @@
3.2.0
3.3.0
4 changes: 0 additions & 4 deletions engine-types/src/types/wei.rs
Original file line number Diff line number Diff line change
Expand Up @@ -159,10 +159,6 @@ impl Wei {
self.0.checked_add(rhs.0).map(Self)
}

pub fn checked_mul(self, rhs: Self) -> Option<Self> {
self.0.checked_mul(rhs.0).map(Self)
}

/// Try convert U256 to u128 with checking overflow.
/// NOTICE: Error can contain only overflow
pub fn try_into_u128(self) -> Result<u128, error::BalanceOverflowError> {
Expand Down
2 changes: 1 addition & 1 deletion engine/Cargo.toml
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
[package]
name = "aurora-engine"
version = "3.2.0"
version = "3.3.0"
authors.workspace = true
edition.workspace = true
homepage.workspace = true
Expand Down

0 comments on commit 016dc72

Please sign in to comment.