-
Notifications
You must be signed in to change notification settings - Fork 83
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
### Additions - Added support of CANCUN hardfork by [@mrLSD]. ([#926]) - Added support of EIP-3607 by [@mrLSD]. ([#930]) - Removed restrictions from funding XCC sub-accounts by [@birchmd]. ([#931]) ### Changes - Made some EVM gas costs optimisations by [@mrLSD]. ([#934]) - Refactored the gas charge logic form EVM exit reasons by [@mrLSD]. ([#935]) - Updated some dependencies and rust-toolchain by [@mrLSD]. ([#936]) - Removed unused `bytes_to_hex` function by [@dwiekawki]. ([#942]) - Added building of actual version of the `near-sandbox` in the scheduled CI job by [@aleksuss] ([#950]) ### Fixes - Removed duplicated `test` task in the `README.md` by [@dwiekawki]. ([#943]) - Fixed some typos in the `README.md` and `Cargo.toml` by [@DemoYeti]. ([#945]) ([#946]) - Fixed exceeded prepaid gas error in the `mirror_erc20_token` transaction by [@aleksuss] ([#951]) - Modified `hardhat.config.js` to support contract verification by [@spilin] ([#958]) [#926]: #926 [#930]: #930 [#931]: #931 [#934]: #934 [#935]: #935 [#936]: #936 [#942]: #942 [#943]: #943 [#945]: #945 [#946]: #946 [#950]: #950 [#951]: #951 [#958]: #958 --------- Signed-off-by: dependabot[bot] <support@github.com> Co-authored-by: Michael Birch <michael.birch@aurora.dev> Co-authored-by: Evgeny Ukhanov <evgeny@aurora.dev> Co-authored-by: dwiekawki <176287097+dwiekawki@users.noreply.github.com> Co-authored-by: dwiekawki <dwiekawki@users.noreply.github.com> Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> Co-authored-by: DemoYeti <164791169+DemoYeti@users.noreply.github.com> Co-authored-by: spilin <LyoshaKR@gmail.com>
- Loading branch information
1 parent
28396c1
commit 338dd61
Showing
66 changed files
with
2,725 additions
and
1,603 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,34 +1,68 @@ | ||
--- | ||
on: | ||
schedule: | ||
- cron: '30 8 * * 1-5' | ||
- cron: '0 9 * * 1-5' | ||
name: Scheduled checks | ||
jobs: | ||
tests: | ||
name: Run tests | ||
runs-on: [self-hosted, heavy] | ||
runs-on: github-hosted-heavy-runner | ||
strategy: | ||
fail-fast: false | ||
matrix: | ||
profile: [ mainnet, mainnet-silo, testnet, testnet-silo ] | ||
steps: | ||
- name: Potential broken submodules fix | ||
run: | | ||
git checkout -f $(git -c user.name=x -c user.email=x@x commit-tree $(git hash-object -t tree /dev/null) < /dev/null) || : | ||
- name: Clone the repository | ||
uses: actions/checkout@v4 | ||
- name: Test mainnet | ||
run: cargo make --profile mainnet test-flow | ||
- name: Test testnet | ||
run: cargo make --profile testnet test-flow | ||
- name: Test mainnet silo | ||
run: cargo make --profile mainnet-silo test-flow | ||
- name: Test testnet silo | ||
run: cargo make --profile testnet-silo test-flow | ||
- name: Cargo Cache | ||
uses: actions/cache@v4 | ||
with: | ||
path: | | ||
~/.cargo/bin/ | ||
~/.cargo/registry/index/ | ||
~/.cargo/registry/cache/ | ||
~/.cargo/git/db/ | ||
target/ | ||
key: ${{ matrix.profile }}-cargo-test | ||
- name: Setup Node and cache | ||
uses: actions/setup-node@v4 | ||
with: | ||
node-version: 16 | ||
cache: 'yarn' | ||
cache-dependency-path: | | ||
etc/eth-contracts | ||
etc/tests/uniswap | ||
- name: Install cargo-make | ||
run: cargo +stable make -V || cargo +stable install cargo-make | ||
- name: Build actual neard-sandbox | ||
run: scripts/build-neard-sandbox.sh ${{ matrix.profile }} | ||
- name: Test ${{ matrix.profile }} | ||
run: cargo make --profile ${{ matrix.profile }} test-flow | ||
- uses: 8398a7/action-slack@v3 | ||
if: failure() | ||
with: | ||
status: ${{ job.status }} | ||
fields: repo,message,commit,author,action,eventName,job,took | ||
env: | ||
SLACK_WEBHOOK_URL: ${{ secrets.SLACK_WEBHOOK_URL }} | ||
|
||
checks: | ||
name: Run checks | ||
runs-on: [self-hosted, heavy] | ||
runs-on: [ self-hosted, heavy ] | ||
steps: | ||
- name: Potential broken submodules fix | ||
run: | | ||
git checkout -f $(git -c user.name=x -c user.email=x@x commit-tree $(git hash-object -t tree /dev/null) < /dev/null) || : | ||
- name: Clone the repository | ||
uses: actions/checkout@v4 | ||
- run: cargo make check | ||
- uses: 8398a7/action-slack@v3 | ||
if: failure() | ||
with: | ||
status: ${{ job.status }} | ||
fields: repo,message,commit,author,action,eventName,job,took | ||
env: | ||
SLACK_WEBHOOK_URL: ${{ secrets.SLACK_WEBHOOK_URL }} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -12,6 +12,7 @@ | |
|
||
# ENV | ||
.env/custom.env | ||
etc/eth-contracts/.env | ||
|
||
# Rust artifacts | ||
bin/ | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Oops, something went wrong.