Skip to content

Commit

Permalink
chore: release notes 3.2.0 (#851)
Browse files Browse the repository at this point in the history
  • Loading branch information
aleksuss authored Oct 17, 2023
1 parent d5b941f commit eb0255f
Show file tree
Hide file tree
Showing 7 changed files with 23 additions and 8 deletions.
17 changes: 16 additions & 1 deletion CHANGES.md
Original file line number Diff line number Diff line change
Expand Up @@ -7,17 +7,31 @@ and this project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0

## [Unreleased]

## [3.2.0] 2023-10-17

### Changes

- Changed structure `SetEthConnectorContractAccountArgs` for setting eth connector account. It was extended with
additional field: `withdraw_serialize_type` for defining serialization type for withdraw arguments by [@aleksuss]. ([#834])

- Updated rocksdb up to 0.21.0 by [@aleksuss]. ([#840])

### Additions

- Added a possibility of mirroring deployed ERC-20 contracts in the main Aurora contract in Silo mode by [@aleksuss]. ([#844])

- Allow to initialize hashchain directly with the `new` method by [@birchmd]. ([#846])

- Added a silo logic which allows to set fixed gas costs per transaction by [@aleksuss]. ([#746])

- Added a new type of transaction which allows to add full access key into account of the smart contract by [@aleksuss]. ([#847])

[#746]: https://github.com/aurora-is-near/aurora-engine/pull/746
[#834]: https://github.com/aurora-is-near/aurora-engine/pull/834
[#840]: https://github.com/aurora-is-near/aurora-engine/pull/840
[#844]: https://github.com/aurora-is-near/aurora-engine/pull/844
[#846]: https://github.com/aurora-is-near/aurora-engine/pull/846
[#847]: https://github.com/aurora-is-near/aurora-engine/pull/847

## [3.1.0] 2023-09-25

Expand Down Expand Up @@ -512,7 +526,8 @@ struct SubmitResult {

## [1.0.0] - 2021-05-12

[Unreleased]: https://github.com/aurora-is-near/aurora-engine/compare/3.1.0...develop
[Unreleased]: https://github.com/aurora-is-near/aurora-engine/compare/3.2.0...develop
[3.2.0]: https://github.com/aurora-is-near/aurora-engine/compare/3.1.0...3.2.0
[3.1.0]: https://github.com/aurora-is-near/aurora-engine/compare/3.0.0...3.1.0
[3.0.0]: https://github.com/aurora-is-near/aurora-engine/compare/3.0.0...2.10.2
[2.10.2]: https://github.com/aurora-is-near/aurora-engine/compare/2.10.1...2.10.2
Expand Down
2 changes: 1 addition & 1 deletion Cargo.lock

Some generated files are not rendered by default. Learn more about how customized files appear on GitHub.

4 changes: 2 additions & 2 deletions Makefile.toml
Original file line number Diff line number Diff line change
Expand Up @@ -319,7 +319,7 @@ run_task = "build-engine-flow-docker"
[tasks.build-docker]
category = "Build"
script = '''
docker run --volume $PWD:/host -w /host -i --rm nearprotocol/contract-builder:master-f033430c4fc619aaf8b88eb2fcb976bb8d24d65d-amd64 ./scripts/docker-entrypoint.sh ${PROFILE}
docker run --volume $PWD:/host -w /host -i --rm nearprotocol/contract-builder:master-15bfb0e6d54ff386478d137074027c2cb863df03-amd64 ./scripts/docker-entrypoint.sh ${PROFILE}
'''

[tasks.build-xcc-router-docker-inner]
Expand All @@ -332,7 +332,7 @@ run_task = "build-xcc-router-flow-docker"
condition = { profiles = ["mainnet", "testnet"] }
category = "Build"
script = '''
docker run --volume $PWD:/host -w /host -i --rm nearprotocol/contract-builder:master-f033430c4fc619aaf8b88eb2fcb976bb8d24d65d-amd64 ./scripts/docker-xcc-router-entrypoint.sh ${PROFILE}
docker run --volume $PWD:/host -w /host -i --rm nearprotocol/contract-builder:master-15bfb0e6d54ff386478d137074027c2cb863df03-amd64 ./scripts/docker-xcc-router-entrypoint.sh ${PROFILE}
'''

[tasks.test-contracts]
Expand Down
2 changes: 1 addition & 1 deletion VERSION
Original file line number Diff line number Diff line change
@@ -1 +1 @@
3.1.0
3.2.0
2 changes: 1 addition & 1 deletion engine-tests/src/benches/eth_standard_precompiles.rs
Original file line number Diff line number Diff line change
Expand Up @@ -59,7 +59,7 @@ pub fn eth_standard_precompiles_benchmark(c: &mut Criterion) {
let mut group = c.benchmark_group("standard_precompiles");

// measure wall-clock time
for (tx_bytes, id) in transactions.iter().zip(bench_ids.into_iter()) {
for (tx_bytes, id) in transactions.iter().zip(bench_ids) {
group.bench_function(id, |b| {
b.iter_batched(
|| (runner.one_shot(), calling_account_id, tx_bytes.clone()),
Expand Down
2 changes: 1 addition & 1 deletion engine-tests/src/tests/standalone/tracing.rs
Original file line number Diff line number Diff line change
Expand Up @@ -212,7 +212,7 @@ fn check_transaction_trace<P: AsRef<Path>>(trace: &TransactionTrace, expected_tr
};

assert_eq!(trace.logs().0.len(), expected_trace.len());
for (log, step) in trace.logs().0.iter().zip(expected_trace.into_iter()) {
for (log, step) in trace.logs().0.iter().zip(expected_trace) {
assert_eq!(
log.program_counter.0, step.pc,
"Program counters should match"
Expand Down
2 changes: 1 addition & 1 deletion engine/Cargo.toml
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
[package]
name = "aurora-engine"
version = "3.1.0"
version = "3.2.0"
authors.workspace = true
edition.workspace = true
homepage.workspace = true
Expand Down

0 comments on commit eb0255f

Please sign in to comment.