-
Notifications
You must be signed in to change notification settings - Fork 56
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
- Loading branch information
Showing
4 changed files
with
144 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
65 changes: 65 additions & 0 deletions
65
dev-dotnet/dotnetcore-sdk-bin-common/dotnetcore-sdk-bin-common-7.0.102.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,65 @@ | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI="7" | ||
|
||
inherit eutils | ||
|
||
MY_PV="${PV}" | ||
|
||
DESCRIPTION="Common files shared between multiple slots of .NET Core" | ||
HOMEPAGE="https://www.microsoft.com/net/core" | ||
LICENSE="MIT" | ||
|
||
SRC_URI=" | ||
amd64? ( https://dotnetcli.azureedge.net/dotnet/Sdk/${MY_PV}/dotnet-sdk-${MY_PV}-linux-x64.tar.gz ) | ||
arm? ( https://dotnetcli.azureedge.net/dotnet/Sdk/${MY_PV}/dotnet-sdk-${MY_PV}-linux-arm.tar.gz ) | ||
arm64? ( https://dotnetcli.azureedge.net/dotnet/Sdk/${MY_PV}/dotnet-sdk-${MY_PV}-linux-arm64.tar.gz ) | ||
" | ||
|
||
SLOT="0" | ||
KEYWORDS="" | ||
|
||
QA_PREBUILT="*" | ||
RESTRICT="splitdebug" | ||
|
||
# The sdk includes the runtime-bin and aspnet-bin so prevent from installing at the same time | ||
# dotnetcore-sdk is the source based build | ||
|
||
RDEPEND=" | ||
~dev-dotnet/dotnetcore-sdk-bin-${PV} | ||
!dev-dotnet/dotnet-sdk[dotnet-symlink(+)] | ||
!dev-dotnet/dotnet-sdk-bin[dotnet-symlink(+)] | ||
" | ||
|
||
S=${WORKDIR} | ||
|
||
src_prepare() { | ||
default | ||
|
||
# For current .NET Core versions, all the directories contain versioned files, | ||
# but the top-level files (the dotnet binary for example) are shared between versions, | ||
# and those are backward-compatible. | ||
# The exception from this above rule is packs/NETStandard.Library.Ref which is shared between >=3.0 versions. | ||
# These common files are installed by the non-slotted dev-dotnet/dotnetcore-sdk-bin-common | ||
# package, while the directories are installed by dev-dotnet/dotnetcore-sdk-bin which uses | ||
# slots depending on major .NET Core version. | ||
# This makes it possible to install multiple major versions at the same time. | ||
|
||
# Skip the versioned files (which are located inside sub-directories) | ||
find . -maxdepth 1 -type d ! -name . ! -name packs -exec rm -rf {} \; || die | ||
find ./packs -maxdepth 1 -type d ! -name packs ! -name NETStandard.Library.Ref -exec rm -rf {} \; || die | ||
} | ||
|
||
src_install() { | ||
local dest="opt/dotnet_core" | ||
dodir "${dest}" | ||
|
||
local ddest="${D}/${dest}" | ||
cp -a "${S}"/* "${ddest}/" || die | ||
dosym "/${dest}/dotnet" "/usr/bin/dotnet" | ||
|
||
# set an env-variable for 3rd party tools | ||
echo -n "DOTNET_ROOT=/${dest}" > "${T}/90dotnet" | ||
doenvd "${T}/90dotnet" | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
73 changes: 73 additions & 0 deletions
73
dev-dotnet/dotnetcore-sdk-bin/dotnetcore-sdk-bin-7.0.102.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,73 @@ | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI="7" | ||
|
||
inherit eutils | ||
|
||
MY_PV="${PV}" | ||
|
||
DESCRIPTION=".NET Core SDK - binary precompiled for glibc" | ||
HOMEPAGE="https://www.microsoft.com/net/core" | ||
LICENSE="MIT" | ||
|
||
SRC_URI=" | ||
amd64? ( https://dotnetcli.azureedge.net/dotnet/Sdk/${MY_PV}/dotnet-sdk-${MY_PV}-linux-x64.tar.gz ) | ||
arm? ( https://dotnetcli.azureedge.net/dotnet/Sdk/${MY_PV}/dotnet-sdk-${MY_PV}-linux-arm.tar.gz ) | ||
arm64? ( https://dotnetcli.azureedge.net/dotnet/Sdk/${MY_PV}/dotnet-sdk-${MY_PV}-linux-arm64.tar.gz ) | ||
" | ||
|
||
SLOT="7.0" | ||
KEYWORDS="" | ||
|
||
QA_PREBUILT="*" | ||
RESTRICT="splitdebug" | ||
|
||
# The sdk includes the runtime-bin and aspnet-bin so prevent from installing at the same time | ||
# dotnetcore-sdk is the source based build | ||
|
||
RDEPEND=" | ||
app-crypt/mit-krb5 | ||
>=dev-dotnet/dotnetcore-sdk-bin-common-${PV} | ||
dev-libs/icu | ||
|| ( dev-libs/openssl dev-libs/openssl-compat:1.0.0 ) | ||
dev-util/lldb | ||
dev-util/lttng-ust | ||
net-misc/curl | ||
sys-apps/lsb-release | ||
sys-devel/llvm | ||
sys-libs/libunwind | ||
sys-libs/zlib" | ||
|
||
S=${WORKDIR} | ||
|
||
src_prepare() { | ||
default | ||
|
||
# For current .NET Core versions, all the directories contain versioned files, | ||
# but the top-level files (the dotnet binary for example) are shared between versions, | ||
# and those are backward-compatible. | ||
# The exception from this above rule is packs/NETStandard.Library.Ref which is shared between >=3.0 versions. | ||
# These common files are installed by the non-slotted dev-dotnet/dotnetcore-sdk-bin-common | ||
# package, while the directories are installed by dev-dotnet/dotnetcore-sdk-bin which uses | ||
# slots depending on major .NET Core version. | ||
# This makes it possible to install multiple major versions at the same time. | ||
|
||
# Skip the common files | ||
find . -maxdepth 1 -type f -exec rm -f {} \; || die | ||
rm -rf ./packs/NETStandard.Library.Ref || die | ||
|
||
# 6.0.100 is SDK feature band which will not change between minor increases, so 6.0.101, 6.102 | ||
# will still have same 6.0.100 SDK feature band in the name. Thus I have to hard code this | ||
# https://github.com/dotnet/sdk/pull/18823#issuecomment-915603684 | ||
local workloads="metadata/workloads/${SLOT}.100" | ||
{ mkdir -p "${workloads}" && touch "${workloads}/userlocal"; } || die | ||
} | ||
|
||
src_install() { | ||
local dest="opt/dotnet_core" | ||
dodir "${dest}" | ||
|
||
local ddest="${D}/${dest}" | ||
cp -a "${S}"/* "${ddest}/" || die | ||
} |