-
Notifications
You must be signed in to change notification settings - Fork 166
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-python/boost-histogram: new package, add 1.4.0
Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de>
- Loading branch information
Showing
3 changed files
with
62 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
DIST boost_histogram-1.4.0.tar.gz 1329002 BLAKE2B 1636ed04c5df2f6c156468ffc0fed7b82469bb903c316b1b9fd209b7072ebb5b0de9969f4f8b50da69db7ee40009df534959db7734f1161da2c6216bddce858b SHA512 e7f61cc2d013a0664646d9edf1f713eb5f06f000ad2105e90229ef9b01b25a08c8e717a2ac241ed990fa2c082a1bb84af18e17b238640de5679d0ab76ff08af6 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,42 @@ | ||
EAPI=8 | ||
|
||
PYTHON_COMPAT=( python3_{10..12} ) | ||
DISTUTILS_USE_PEP517=setuptools | ||
inherit distutils-r1 pypi | ||
|
||
DESCRIPTION="Python bindings for the C++14 Boost::Histogram library" | ||
HOMEPAGE="https://github.com/scikit-hep/boost-histogram" | ||
|
||
LICENSE="BSD" | ||
SLOT="0" | ||
KEYWORDS="~amd64" | ||
|
||
RDEPEND=" | ||
dev-libs/boost[python,${PYTHON_USEDEP}] | ||
dev-python/numpy[${PYTHON_USEDEP}] | ||
test? ( | ||
dev-python/pytest[${PYTHON_USEDEP}] | ||
dev-python/cloudpickle[${PYTHON_USEDEP}] | ||
dev-python/hypothesis[${PYTHON_USEDEP}] | ||
) | ||
" | ||
BDEPEND="${RDEPEND}" | ||
|
||
src_prepare() { | ||
default | ||
sed -i 's/"pytest-benchmark"//g' pyproject.toml || die | ||
} | ||
|
||
distutils_enable_tests pytest | ||
|
||
python_test() { | ||
# Remove benchmarks from tests | ||
local EPYTEST_IGNORE=( | ||
tests/test_benchmark_1d.py | ||
tests/test_benchmark_2d.py | ||
tests/test_benchmark_category_axis.py | ||
tests/test_pickle.py | ||
tests/test_threaded_fill.py | ||
) | ||
epytest | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,19 @@ | ||
<?xml version="1.0" encoding="UTF-8"?> | ||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd"> | ||
<pkgmetadata> | ||
<maintainer type="project"> | ||
<email>sci@gentoo.org</email> | ||
<name>Gentoo Science Project</name> | ||
</maintainer> | ||
<maintainer type="person"> | ||
<email>alexander@neuwirth-informatik.de</email> | ||
<name>Alexander Puck Neuwirth</name> | ||
</maintainer> | ||
<longdescription lang="en"> | ||
Python bindings for Boost::Histogram (source), a C++14 library. This is one of the fastest libraries for histogramming, while still providing the power of a full histogram object. See what's new. | ||
</longdescription> | ||
<upstream> | ||
<remote-id type="pypi">boost-histogram</remote-id> | ||
<remote-id type="github">scikit-hep/boost-histogram</remote-id> | ||
</upstream> | ||
</pkgmetadata> |