Skip to content

Commit

Permalink
sci-physics/cuttools: Unbundle deps
Browse files Browse the repository at this point in the history
Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de>
  • Loading branch information
APN-Pucky committed Nov 20, 2024
1 parent b5ba01d commit 21a1af5
Show file tree
Hide file tree
Showing 2 changed files with 70 additions and 0 deletions.
57 changes: 57 additions & 0 deletions sci-physics/cuttools/cuttools-1.9.3-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,57 @@
# Copyright 2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit fortran-2 toolchain-funcs

DESCRIPTION="Computing 1-loop amplitudes at the integrand level"
HOMEPAGE="https://www.ugr.es/~pittau/CutTools/"
SRC_URI="https://www.ugr.es/~pittau/CutTools/${PN}_v${PV}.tar.gz"
S="${WORKDIR}"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"

IUSE="+dummy"
DEPEND="
sci-libs/mpfun90
sci-physics/qcdloop
sci-physics/oneloop[dpkind,qpkind16,-qpkind,-tlevel]
"
RDEPEND="${DEPEND}"

PATCHES=(
"${FILESDIR}/${PN}-1.9.3-unbundle.patch"
)

src_prepare() {
default
sed -i 's/^ALL =.*$/ALL = $(CTS)/' src/makefile || die
if use dummy ; then
cp "${FILESDIR}"/mpnumdummy.f90 src/cts/mpnumdummy.f90 || die
fi
if use dummy ; then
sed -i 's/CTS =/CTS = mpnumdummy.o/' src/makefile || die
fi
}

src_compile() {
emake -j1 FFLAGS="${FFLAGS} -I${ESYSROOT}/usr/include -fPIC -std=legacy"
tc-export AR CXX
cd includects || die
${AR} -x libcts.a || die
${CXX} ${CXXFLAGS} ${LDFLAGS} -shared *.o -Wl,-soname,libcuttools.so -o lib${PN}.so || die
}

src_install() {
cd includects || die
dolib.so lib${PN}.so
cd .. || die
mv includects ${PN} || die
rm ${PN}/*.a || die
rm ${PN}/*.so || die
rm ${PN}/*.o || die
doheader -r ${PN}
}
13 changes: 13 additions & 0 deletions sci-physics/cuttools/files/cuttools-1.9.3-unbundle.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,13 @@
--- a/makefile 2024-11-20 15:50:21.960336440 +0100
+++ b/makefile 2024-11-20 15:50:51.503676969 +0100
@@ -51,10 +51,7 @@

$(BLD)/version.h:
-mkdir -p $(BLD)
- cp -p ./src/avh/* $(BLD)/
cp -p ./src/cts/* $(BLD)/
- cp -p ./src/mpfun90/* $(BLD)/
- cp -p ./src/qcdloop/* $(BLD)/
cp -p ./src/makefile $(BLD)/

tar:

0 comments on commit 21a1af5

Please sign in to comment.