Skip to content

Commit

Permalink
sci-libs/rdkit: version bump 2024.03.4
Browse files Browse the repository at this point in the history
Signed-off-by: Michael Schubert <mschu.dev@gmail.com>
Closes: #1288
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
  • Loading branch information
mschubert authored and Nowa-Ammerlaan committed Oct 30, 2024
1 parent 98ac6bd commit bb32520
Show file tree
Hide file tree
Showing 5 changed files with 47 additions and 33 deletions.
2 changes: 1 addition & 1 deletion sci-libs/rdkit/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1 @@
DIST rdkit-2021.09.4.tar.gz 78474802 BLAKE2B 8c78c787a0e414b5e035998d9575322edca955acecb6d2df173610398f91cffd0b9053e7fc2c9284a2117afd720f313b7a63ed7e9ab67c708f25a5735b838f59 SHA512 c761fd5c3340ec38141165996b8666c3dcd4ed46ab91ca0d5a43ae3daedfc423ae36ec5882f085e1bd0c4c13dfe1f09497d05ec95e4847048c0acff8bcd0b1db
DIST rdkit-2024.03.4.tar.gz 80452802 BLAKE2B 2f121ccb1f590848d2415a63a0a891e9c107334d2e11b31829415b73f64a2f6aeeb99eaafc0fa3ebd99c72bd9bb5ac1eef5c00f6eabf397561de1e7202c91719 SHA512 4c9737e29e21aab6271e427160fc24179410d98119d728b95da94be0dcd1f75f5cab45f8ea52e4dda8abed5c6af386f1f0d671d55e7053d108ca7a51e5584cf1
22 changes: 0 additions & 22 deletions sci-libs/rdkit/files/rdkit-2021.09.4-find-rapidjson.patch

This file was deleted.

40 changes: 40 additions & 0 deletions sci-libs/rdkit/files/rdkit-2024.03.4-find-rapidjson.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
diff --git a/Code/GraphMol/MolInterchange/CMakeLists.txt b/Code/GraphMol/MolInterchange/CMakeLists.txt
index 0c1e9a0de..e6f4fe753 100644
--- a/Code/GraphMol/MolInterchange/CMakeLists.txt
+++ b/Code/GraphMol/MolInterchange/CMakeLists.txt
@@ -1,24 +1,5 @@

-if(NOT EXISTS "${CMAKE_SOURCE_DIR}/External/rapidjson-1.1.0")
- downloadAndCheckMD5("https://github.com/Tencent/rapidjson/archive/v1.1.0.tar.gz"
- "${CMAKE_SOURCE_DIR}/External/rapidjson-1.1.0.tar.gz"
- "badd12c511e081fec6c89c43a7027bce")
- execute_process(COMMAND ${CMAKE_COMMAND} -E tar zxf
- ${CMAKE_SOURCE_DIR}/External/rapidjson-1.1.0.tar.gz
- WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}/External)
- # comment out a line which causes a compilation error on some platforms
- # (based on the change which has already been applied to the RapidJSON master branch, see
- # https://github.com/Tencent/rapidjson/blob/ab1842a2dae061284c0a62dca1cc6d5e7e37e346/include/rapidjson/document.h#L414)
- file(READ ${CMAKE_SOURCE_DIR}/External/rapidjson-1.1.0/include/rapidjson/document.h RAPIDJSON_DOCUMENT_H)
- string(REGEX REPLACE
- "( *)(GenericStringRef& operator=\\(const GenericStringRef& rhs\\) { s = rhs\\.s. length = rhs\\.length. })" "\\1//\\2"
- RAPIDJSON_DOCUMENT_H "${RAPIDJSON_DOCUMENT_H}")
- file(WRITE ${CMAKE_SOURCE_DIR}/External/rapidjson-1.1.0/include/rapidjson/document.h "${RAPIDJSON_DOCUMENT_H}")
-else()
- message("-- Found RapidJSON source in ${CMAKE_SOURCE_DIR}/External")
-endif()
-
-include_directories(${CMAKE_SOURCE_DIR}/External/rapidjson-1.1.0/include)
+include_directories(/usr/include/rapidjson)


rdkit_library(MolInterchange
diff --git a/Code/MinimalLib/CMakeLists.txt b/Code/MinimalLib/CMakeLists.txt
index 84808a971..987b155f8 100644
--- a/Code/MinimalLib/CMakeLists.txt
+++ b/Code/MinimalLib/CMakeLists.txt
@@ -1,5 +1,4 @@
include_directories(${RDKit_ExternalDir})
-include_directories(${RDKit_ExternalDir}/rapidjson-1.1.0/include)

if(RDK_BUILD_MINIMAL_LIB)
set(MINIMAL_LIB_LIBRARIES "MolInterchange_static;Abbreviations_static;"
4 changes: 0 additions & 4 deletions sci-libs/rdkit/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -5,10 +5,6 @@
<email>mschu.dev@gmail.com</email>
<name>Michael Schubert</name>
</maintainer>
<maintainer type="project">
<email>sci-chemistry@gentoo.org</email>
<name>Gentoo Chemistry Project</name>
</maintainer>
<upstream>
<remote-id type="github">rdkit/rdkit</remote-id>
</upstream>
Expand Down
Original file line number Diff line number Diff line change
@@ -1,14 +1,15 @@
# Copyright 1999-2022 Gentoo Authors
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_10 )
PYTHON_COMPAT=( python3_{10..12} )
CMAKE_IN_SOURCE_BUILD=1

inherit cmake python-single-r1

DESCRIPTION="Cheminformatics and machine-learning software written in C++ and Python"
HOMEPAGE="http://www.rdkit.org/"
HOMEPAGE="https://www.rdkit.org/"
SRC_URI="https://github.com/rdkit/rdkit/archive/Release_${PV//./_}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/rdkit-Release_${PV//./_}"

Expand All @@ -33,12 +34,11 @@ RDEPEND="dev-libs/boost
DEPEND="${RDEPEND}"

PATCHES=(
"${FILESDIR}/${PN}-2021.09.4-find-rapidjson.patch"
"${FILESDIR}/${PN}-2024.03.4-find-rapidjson.patch"
)

src_configure() {
local mycmakeargs=(
-DCATCH_DIR="${EPREFIX}/usr/include/catch2"
-DCMAKE_INSTALL_PREFIX:PATH="${EPREFIX}/usr"
-DRDK_INSTALL_INTREE=0
-DRDK_BUILD_CPP_TESTS="$(usex test)"
Expand All @@ -54,5 +54,5 @@ src_configure() {
}

src_test() {
RDBASE="${WORKDIR}/${PN}-Release_2021_09_4_build" cmake_src_test
RDBASE="${S}" cmake_src_test
}

0 comments on commit bb32520

Please sign in to comment.