-
Notifications
You must be signed in to change notification settings - Fork 164
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
sci-libs/rdkit: version bump 2024.03.4
Signed-off-by: Michael Schubert <mschu.dev@gmail.com> Closes: #1288 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
- Loading branch information
1 parent
98ac6bd
commit bb32520
Showing
5 changed files
with
47 additions
and
33 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1 @@ | ||
DIST rdkit-2021.09.4.tar.gz 78474802 BLAKE2B 8c78c787a0e414b5e035998d9575322edca955acecb6d2df173610398f91cffd0b9053e7fc2c9284a2117afd720f313b7a63ed7e9ab67c708f25a5735b838f59 SHA512 c761fd5c3340ec38141165996b8666c3dcd4ed46ab91ca0d5a43ae3daedfc423ae36ec5882f085e1bd0c4c13dfe1f09497d05ec95e4847048c0acff8bcd0b1db | ||
DIST rdkit-2024.03.4.tar.gz 80452802 BLAKE2B 2f121ccb1f590848d2415a63a0a891e9c107334d2e11b31829415b73f64a2f6aeeb99eaafc0fa3ebd99c72bd9bb5ac1eef5c00f6eabf397561de1e7202c91719 SHA512 4c9737e29e21aab6271e427160fc24179410d98119d728b95da94be0dcd1f75f5cab45f8ea52e4dda8abed5c6af386f1f0d671d55e7053d108ca7a51e5584cf1 |
This file was deleted.
Oops, something went wrong.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,40 @@ | ||
diff --git a/Code/GraphMol/MolInterchange/CMakeLists.txt b/Code/GraphMol/MolInterchange/CMakeLists.txt | ||
index 0c1e9a0de..e6f4fe753 100644 | ||
--- a/Code/GraphMol/MolInterchange/CMakeLists.txt | ||
+++ b/Code/GraphMol/MolInterchange/CMakeLists.txt | ||
@@ -1,24 +1,5 @@ | ||
|
||
-if(NOT EXISTS "${CMAKE_SOURCE_DIR}/External/rapidjson-1.1.0") | ||
- downloadAndCheckMD5("https://github.com/Tencent/rapidjson/archive/v1.1.0.tar.gz" | ||
- "${CMAKE_SOURCE_DIR}/External/rapidjson-1.1.0.tar.gz" | ||
- "badd12c511e081fec6c89c43a7027bce") | ||
- execute_process(COMMAND ${CMAKE_COMMAND} -E tar zxf | ||
- ${CMAKE_SOURCE_DIR}/External/rapidjson-1.1.0.tar.gz | ||
- WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}/External) | ||
- # comment out a line which causes a compilation error on some platforms | ||
- # (based on the change which has already been applied to the RapidJSON master branch, see | ||
- # https://github.com/Tencent/rapidjson/blob/ab1842a2dae061284c0a62dca1cc6d5e7e37e346/include/rapidjson/document.h#L414) | ||
- file(READ ${CMAKE_SOURCE_DIR}/External/rapidjson-1.1.0/include/rapidjson/document.h RAPIDJSON_DOCUMENT_H) | ||
- string(REGEX REPLACE | ||
- "( *)(GenericStringRef& operator=\\(const GenericStringRef& rhs\\) { s = rhs\\.s. length = rhs\\.length. })" "\\1//\\2" | ||
- RAPIDJSON_DOCUMENT_H "${RAPIDJSON_DOCUMENT_H}") | ||
- file(WRITE ${CMAKE_SOURCE_DIR}/External/rapidjson-1.1.0/include/rapidjson/document.h "${RAPIDJSON_DOCUMENT_H}") | ||
-else() | ||
- message("-- Found RapidJSON source in ${CMAKE_SOURCE_DIR}/External") | ||
-endif() | ||
- | ||
-include_directories(${CMAKE_SOURCE_DIR}/External/rapidjson-1.1.0/include) | ||
+include_directories(/usr/include/rapidjson) | ||
|
||
|
||
rdkit_library(MolInterchange | ||
diff --git a/Code/MinimalLib/CMakeLists.txt b/Code/MinimalLib/CMakeLists.txt | ||
index 84808a971..987b155f8 100644 | ||
--- a/Code/MinimalLib/CMakeLists.txt | ||
+++ b/Code/MinimalLib/CMakeLists.txt | ||
@@ -1,5 +1,4 @@ | ||
include_directories(${RDKit_ExternalDir}) | ||
-include_directories(${RDKit_ExternalDir}/rapidjson-1.1.0/include) | ||
|
||
if(RDK_BUILD_MINIMAL_LIB) | ||
set(MINIMAL_LIB_LIBRARIES "MolInterchange_static;Abbreviations_static;" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters