Skip to content

Commit

Permalink
sci-physics/sherpa: new package, add 3.0.0_beta1, 9999
Browse files Browse the repository at this point in the history
Closes: #1279
Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de>
  • Loading branch information
APN-Pucky committed Jun 27, 2024
1 parent bbb29d6 commit c3ee0bf
Show file tree
Hide file tree
Showing 4 changed files with 216 additions and 0 deletions.
1 change: 1 addition & 0 deletions sci-physics/sherpa/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST sherpa-v3.0.0beta1.tar.bz2 5836616 BLAKE2B 5347b6a83b80b148740c6fbf44c4d8f547a30eb85ba70ae4ad620cb3cca3f9d8255c45502969a83dca98d2825207a192ac3cae11dc3b914afdaaf9d65f2e6932 SHA512 9c34851193227a233c962b19cdff00302608d1695841d97de09d2bd40b84ccbd2a2a9f3c89e68e288bdf522e9b4c7fb8fc52032f199014898ac6bacbf628c8ce
27 changes: 27 additions & 0 deletions sci-physics/sherpa/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,27 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>APN-Pucky@users.noreply.github.com</email>
<name>APN-Pucky</name>
</maintainer>
<longdescription lang="en">
Sherpa is a Monte Carlo event generator for the Simulation of High-Energy Reactions of PArticles in lepton-lepton, lepton-photon, photon-photon, lepton-hadron and hadron-hadron collisions. Simulation programs - also dubbed event generators - like Sherpa are indispensable work horses for current particle physics phenomenology and are (at) the interface between theory and experiment.
</longdescription>
<upstream>
<remote-id type="gitlab">sherpa-team/sherpa</remote-id>
</upstream>
<use>
<flag name="hepmc2">Build with HepMC2</flag>
<flag name="fastjet">Build with FastJet</flag>
<flag name="pythia6">Build with Pythia6</flag>
<flag name="pythia8">Build with Pythia8</flag>
<flag name="rivet">Build with Rivet</flag>
<flag name="root">Build with Root</flag>
<flag name="ufo">UFO python interface</flag>
<flag name="lhole">lhole support</flag>
<flag name="analysis">analysis support</flag>
<flag name="openloops">Openloops support</flag>
</use>

</pkgmetadata>
94 changes: 94 additions & 0 deletions sci-physics/sherpa/sherpa-3.0.0_beta1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,94 @@
# Copyright 2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{10..13} )

inherit cmake fortran-2 python-single-r1

MY_PN="SHERPA-MC"
MY_PV=${PV//_/}
MY_P=${MY_PN}-${MY_PV}

DESCRIPTION="Simulation of High-Energy Reactions of PArticles"
HOMEPAGE="
https://sherpa-team.gitlab.io/
https://gitlab.com/sherpa-team/sherpa
"

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://gitlab.com/sherpa-team/sherpa"
EGIT_BRANCH="master"
else
#SRC_URI="https://www.hepforge.org/archive/sherpa/${MY_P}.tar.gz"
SRC_URI="https://gitlab.com/sherpa-team/${PN}/-/archive/v${MY_PV}/${PN}-v${MY_PV}.tar.bz2"
S="${WORKDIR}/${PN}-v${MY_PV}"
KEYWORDS="~amd64"
fi

LICENSE="GPL-3"
SLOT="0"

IUSE="+fastjet +pythia6 pythia8 rivet ufo hepmc2 root gzip mpi lhole analysis openloops" # blackhat recola gosam hztool madloop pgs mcfm
REQUIRED_USE="
ufo? ( ${PYTHON_REQUIRED_USE} )
"

DEPEND="
sci-physics/lhapdf
dev-db/sqlite:3=
sci-physics/hepmc:3=
dev-libs/libzip
rivet? ( sci-physics/rivet )
gzip? ( app-arch/gzip )
pythia8? ( sci-physics/pythia:8= )
hepmc2? ( sci-physics/hepmc:2= )
fastjet? ( sci-physics/fastjet )
root? ( sci-physics/root )
mpi? ( virtual/mpi[cxx,fortran] )
ufo? ( ${PYTHON_DEPS} )
openloops? ( sci-physics/openloops )
"
# blackhat? ( sci-physics/blackhat )
# gosam? ( sci-physics/gosam )
# recola? ( sci-physics/recola )
RDEPEND="${DEPEND}"

pkg_setup() {
use ufo && python-single-r1_pkg_setup
}

src_configure() {
local mycmakeargs=(
-DSHERPA_ENABLE_THREADING=ON
-DSHERPA_ENABLE_ANALYSIS=$(usex analysis ON OFF)
-DSHERPA_ENABLE_GZIP=$(usex gzip ON OFF)
-DSHERPA_ENABLE_HEPMC2=$(usex hepmc2 ON OFF)
-DSHERPA_ENABLE_HEPMC3=ON
-DSHERPA_ENABLE_LHAPDF=ON
-DSHERPA_ENABLE_LHOLE=$(usex lhole ON OFF)
-DSHERPA_ENABLE_MPI=$(usex mpi ON OFF)
$(usex mpi -DCMAKE_C_COMPILER=mpicc)
$(usex mpi -DCMAKE_CXX_COMPILER=mpic++)
$(usex mpi -DCMAKE_Fortran_COMPILER=mpif90)
-DSHERPA_ENABLE_PYTHIA6=$(usex pythia6 ON OFF)
-DSHERPA_ENABLE_PYTHIA8=$(usex pythia8 ON OFF)
-DSHERPA_ENABLE_RIVET=$(usex rivet ON OFF)
-DSHERPA_ENABLE_ROOT=$(usex root ON OFF)
-DSHERPA_ENABLE_UFO=$(usex ufo ON OFF)
-DSHERPA_ENABLE_OPENLOOPS=$(usex openloops ON OFF)
-DOPENLOOPS_PREFIX=$(usex openloops "${ESYSROOT}/opt/OpenLoops2")
#-DSHERPA_ENABLE_GOSAM=$(usex gosam ON OFF)
#-DSHERPA_ENABLE_BLACKHAT=$(usex blackhat ON OFF)
#-DSHERPA_ENABLE_RECOLA=$(usex recola ON OFF)
)
cmake_src_configure
}

src_install() {
cmake_src_install

use ufo && python_optimize
}
94 changes: 94 additions & 0 deletions sci-physics/sherpa/sherpa-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,94 @@
# Copyright 2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{10..13} )

inherit cmake fortran-2 python-single-r1

MY_PN="SHERPA-MC"
MY_PV=${PV//_/}
MY_P=${MY_PN}-${MY_PV}

DESCRIPTION="Simulation of High-Energy Reactions of PArticles"
HOMEPAGE="
https://sherpa-team.gitlab.io/
https://gitlab.com/sherpa-team/sherpa
"

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://gitlab.com/sherpa-team/sherpa"
EGIT_BRANCH="master"
else
#SRC_URI="https://www.hepforge.org/archive/sherpa/${MY_P}.tar.gz"
SRC_URI="https://gitlab.com/sherpa-team/${PN}/-/archive/v${MY_PV}/${PN}-v${MY_PV}.tar.bz2"
S="${WORKDIR}/${PN}-v${MY_PV}"
KEYWORDS="~amd64"
fi

LICENSE="GPL-3"
SLOT="0"

IUSE="+fastjet +pythia6 pythia8 rivet ufo hepmc2 root gzip mpi lhole analysis openloops" # blackhat recola gosam hztool madloop pgs mcfm
REQUIRED_USE="
ufo? ( ${PYTHON_REQUIRED_USE} )
"

DEPEND="
sci-physics/lhapdf
dev-db/sqlite:3=
sci-physics/hepmc:3=
dev-libs/libzip
rivet? ( sci-physics/rivet )
gzip? ( app-arch/gzip )
pythia8? ( sci-physics/pythia:8= )
hepmc2? ( sci-physics/hepmc:2= )
fastjet? ( sci-physics/fastjet )
root? ( sci-physics/root )
mpi? ( virtual/mpi[cxx,fortran] )
ufo? ( ${PYTHON_DEPS} )
openloops? ( sci-physics/openloops )
"
# blackhat? ( sci-physics/blackhat )
# gosam? ( sci-physics/gosam )
# recola? ( sci-physics/recola )
RDEPEND="${DEPEND}"

pkg_setup() {
use ufo && python-single-r1_pkg_setup
}

src_configure() {
local mycmakeargs=(
-DSHERPA_ENABLE_THREADING=ON
-DSHERPA_ENABLE_ANALYSIS=$(usex analysis ON OFF)
-DSHERPA_ENABLE_GZIP=$(usex gzip ON OFF)
-DSHERPA_ENABLE_HEPMC2=$(usex hepmc2 ON OFF)
-DSHERPA_ENABLE_HEPMC3=ON
-DSHERPA_ENABLE_LHAPDF=ON
-DSHERPA_ENABLE_LHOLE=$(usex lhole ON OFF)
-DSHERPA_ENABLE_MPI=$(usex mpi ON OFF)
$(usex mpi -DCMAKE_C_COMPILER=mpicc)
$(usex mpi -DCMAKE_CXX_COMPILER=mpic++)
$(usex mpi -DCMAKE_Fortran_COMPILER=mpif90)
-DSHERPA_ENABLE_PYTHIA6=$(usex pythia6 ON OFF)
-DSHERPA_ENABLE_PYTHIA8=$(usex pythia8 ON OFF)
-DSHERPA_ENABLE_RIVET=$(usex rivet ON OFF)
-DSHERPA_ENABLE_ROOT=$(usex root ON OFF)
-DSHERPA_ENABLE_UFO=$(usex ufo ON OFF)
-DSHERPA_ENABLE_OPENLOOPS=$(usex openloops ON OFF)
-DOPENLOOPS_PREFIX=$(usex openloops "${ESYSROOT}/opt/OpenLoops2")
#-DSHERPA_ENABLE_GOSAM=$(usex gosam ON OFF)
#-DSHERPA_ENABLE_BLACKHAT=$(usex blackhat ON OFF)
#-DSHERPA_ENABLE_RECOLA=$(usex recola ON OFF)
)
cmake_src_configure
}

src_install() {
cmake_src_install

use ufo && python_optimize
}

0 comments on commit c3ee0bf

Please sign in to comment.