Skip to content

Commit

Permalink
dev-python/nptyping: new package, add 2.5.0
Browse files Browse the repository at this point in the history
Signed-off-by: Horea Christian <chr@chymera.eu>
  • Loading branch information
TheChymera committed Dec 1, 2023
1 parent 9e3e033 commit c742e16
Show file tree
Hide file tree
Showing 3 changed files with 82 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/nptyping/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST nptyping-2.5.0.gh.tar.gz 72870 BLAKE2B 16c6cb90c36bbf0b97da5ff74cee7030c641ef76d055cc5691b9d83adab2714d6e3515fd4e8616fece74606e109e6b115348964614b408df06b4f5c3cbccce37 SHA512 2cde9c5f7694d4f916b85c93b86df7f72709a70b2ffa91b7bbc98c5884236f5b36bb545a89c37e8c02a9b460065c97151d77c64f8d93b92fd93bcff406f039d9
15 changes: 15 additions & 0 deletions dev-python/nptyping/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>sci@gentoo.org</email>
<name>Gentoo Science Project</name>
</maintainer>
<maintainer type="person">
<email>gentoo@chymera.eu</email>
<name>Horea Christian</name>
</maintainer>
<remote-id type="pypi">nptyping</remote-id>
<remote-id type="github">ramonhagenaars/nptyping</remote-id>
</upstream>
</pkgmetadata>
66 changes: 66 additions & 0 deletions dev-python/nptyping/nptyping-2.5.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,66 @@
# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{9..11} )

inherit distutils-r1

DESCRIPTION="Type hints for Numpy"
HOMEPAGE="
https://pypi.org/project/nptyping/
https://github.com/ramonhagenaars/nptyping/
"
SRC_URI="
https://github.com/ramonhagenaars/nptyping/archive/v${PV}.tar.gz
-> ${P}.gh.tar.gz
"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"

RDEPEND="
dev-python/numpy[${PYTHON_USEDEP}]
"
BDEPEND="
test? (
dev-python/mypy[${PYTHON_USEDEP}]
dev-python/pandas-stubs[${PYTHON_USEDEP}]
dev-python/typeguard[${PYTHON_USEDEP}]
dev-python/beartype[${PYTHON_USEDEP}]
)
"

EPYTEST_IGNORE=(
# requires pyright, which is not yet packaged
tests/test_pyright.py
# requires Internet + feedparser, meaningless for users
tests/test_package_info.py
# relying on Internet access to fetch packages for pip
tests/test_wheel.py
tests/pandas_/test_fork_sync.py
)

EPYTEST_DESELECT=(
# Reported upstream:
# https://github.com/ramonhagenaars/nptyping/issues/113
tests/test_mypy.py::MyPyTest::test_mypy_accepts_ndarray_with_any
tests/test_mypy.py::MyPyTest::test_mypy_accepts_ndarray_with_shape
tests/test_mypy.py::MyPyTest::test_mypy_accepts_ndarray_with_structure
tests/test_mypy.py::MyPyTest::test_mypy_accepts_ndarrays_as_function_arguments
tests/test_mypy.py::MyPyTest::test_mypy_accepts_ndarrays_as_variable_hints
tests/test_mypy.py::MyPyTest::test_mypy_accepts_nptyping_types
tests/test_mypy.py::MyPyTest::test_mypy_accepts_numpy_types
tests/test_mypy.py::MyPyTest::test_mypy_accepts_recarray_with_structure
tests/test_mypy.py::MyPyTest::test_mypy_disapproves_ndarray_with_wrong_function_arguments
tests/test_mypy.py::MyPyTest::test_mypy_knows_of_ndarray_methods
tests/test_typeguard.py::TypeguardTest::test_success
tests/pandas_/test_mypy_dataframe.py::MyPyDataFrameTest::test_mypy_accepts_dataframe
tests/pandas_/test_mypy_dataframe.py::MyPyDataFrameTest::test_mypy_disapproves_dataframe_with_wrong_function_arguments
tests/pandas_/test_mypy_dataframe.py::MyPyDataFrameTest::test_mypy_knows_of_dataframe_methods
)

distutils_enable_tests pytest

0 comments on commit c742e16

Please sign in to comment.