-
Notifications
You must be signed in to change notification settings - Fork 165
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Signed-off-by: Horea Christian <chr@chymera.eu>
- Loading branch information
1 parent
499bf58
commit e574813
Showing
3 changed files
with
42 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,10 @@ | ||
--- a/pyproject.toml 2020-02-01 19:00:00.000000000 -0500 | ||
+++ b/pyproject.toml 2023-12-11 12:00:19.368474488 -0500 | ||
@@ -76,7 +76,6 @@ | ||
# verbose = 1 | ||
|
||
[tool.pytest.ini_options] | ||
-addopts = "--cov --cov-report html" | ||
norecursedirs = "tests/unit/helpers" | ||
|
||
[tool.codespell] |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,31 @@ | ||
# Copyright 1999-2023 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
DISTUTILS_USE_PEP517=hatchling | ||
PYTHON_COMPAT=( python3_{10..11} ) | ||
inherit distutils-r1 pypi | ||
|
||
DESCRIPTION="The Hierarchical Data Modeling Framework" | ||
HOMEPAGE="https://github.com/hdmf-dev/hdmf" | ||
SRC_URI="$(pypi_sdist_url hdmf)" | ||
|
||
SLOT="0" | ||
LICENSE="BSD" | ||
KEYWORDS="~amd64 ~x86" | ||
|
||
RDEPEND=" | ||
dev-python/h5py[${PYTHON_USEDEP}] | ||
dev-python/jsonschema[${PYTHON_USEDEP}] | ||
dev-python/numpy[${PYTHON_USEDEP}] | ||
dev-python/pandas[${PYTHON_USEDEP}] | ||
dev-python/ruamel-yaml[${PYTHON_USEDEP}] | ||
dev-python/scipy[${PYTHON_USEDEP}] | ||
" | ||
|
||
PATCHES=( | ||
"${FILESDIR}/${P}-no_test_coverage.patch" | ||
) | ||
|
||
distutils_enable_tests pytest |