Skip to content

Commit

Permalink
fixup! perl: update to 5.38.0
Browse files Browse the repository at this point in the history
  • Loading branch information
rimrul committed Jul 13, 2023
1 parent 5eb79ed commit 9ce7eca
Show file tree
Hide file tree
Showing 6 changed files with 60 additions and 89 deletions.
30 changes: 30 additions & 0 deletions perl/0001-fix-various-pods.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,30 @@
From 95d30af67bcbe14a0755e24c85400affc01eac20 Mon Sep 17 00:00:00 2001
From: Matthias Aßhauer <mha1993@live.de>
Date: Wed, 12 Jul 2023 11:41:32 +0200
Subject: [PATCH 1/7] fix paths for various .pod files

---
Makefile.SH | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/cpan/Win32/t/GetShortPathName.t b/cpan/Win32/t/GetShortPathName.t
index 649420a..82ce2d5 100644
--- a/Makefile.SH
+++ b/Makefile.SH
@@ -1142,14 +1142,14 @@

pod/perl5380delta.pod: pod/perldelta.pod
$(RMS) pod/perl5380delta.pod
- $(LNS) perldelta.pod pod/perl5380delta.pod
+ $(LNS) pod/perldelta.pod pod/perl5380delta.pod

extra.pods: $(MINIPERL_EXE)
-@test ! -f extra.pods || rm -f `cat extra.pods`
-@rm -f extra.pods
-@for x in `grep -l '^=[a-z]' README.* | grep -v README.vms` ; do \
nx=`echo $$x | sed -e "s/README\.//"`; \
- $(LNS) ../$$x "pod/perl"$$nx".pod" ; \
+ $(LNS) ./$$x "pod/perl"$$nx".pod" ; \
echo "pod/perl"$$nx".pod" >> extra.pods ; \
done

25 changes: 0 additions & 25 deletions perl/0001-perl.cygwin-auto-image-base.patch

This file was deleted.

19 changes: 9 additions & 10 deletions perl/0002-perl.cygwin-hints.patch
Original file line number Diff line number Diff line change
Expand Up @@ -11,28 +11,27 @@ diff --git a/hints/cygwin.sh b/hints/cygwin.sh
index 40edf5f..bda3da8 100644
--- a/hints/cygwin.sh
+++ b/hints/cygwin.sh
@@ -25,12 +25,21 @@ libswanted=`echo " $libswanted " | sed -e 's/ c / /g'`
@@ -25,13 +25,13 @@ libswanted=`echo " $libswanted " | sed -e 's/ c / /g'`
libswanted=`echo " $libswanted " | sed -e 's/ m / /g'`
# - eliminate -lutil, symbols are all in libcygwin.a
libswanted=`echo " $libswanted " | sed -e 's/ util / /g'`
-test -z "$ignore_versioned_solibs" && ignore_versioned_solibs='y'
-test -z "$usenm" && usenm='no'
-test -z "$libc" && libc='/usr/lib/libcygwin.a'
-test -z "$loclibpth" && loclibpth=' '
-test -z "$glibpth" && glibpth=' '
-test -z "$plibpth" && plibpth=' '
-test -z "$libpth" && libpth=' '
+ignore_versioned_solibs='y'
+usenm='no'
+libc='/usr/lib/libcygwin.a'
+loclibpth=' '
+glibpth=' '
+plibpth=' '
+libpth=' '
+PATH='.:/usr/bin/'
PATH='.:/usr/bin/'
# - add libgdbm_compat $libswanted
libswanted="$libswanted gdbm_compat"
test -z "$optimize" && optimize='-O3'
man3ext='3pm'
test -z "$use64bitint" && use64bitint='define'
test -z "$useithreads" && useithreads='define'
+test -z "$usemymalloc" && usemymalloc='undef'
ccflags="$ccflags -DPERL_USE_SAFE_PUTENV -U__STRICT_ANSI__ -D_GNU_SOURCE"
# - otherwise i686-cygwin
archname='cygwin'
@@ -62,6 +71,13 @@ case "$osvers" in
d_inetpton='undef'
esac
Expand Down
55 changes: 11 additions & 44 deletions perl/0003-perl.cygwin-Configure-libsearch.patch
Original file line number Diff line number Diff line change
Expand Up @@ -4,8 +4,8 @@ Date: Tue, 14 Feb 2017 14:45:21 +0300
Subject: [PATCH 3/7] perl.cygwin-Configure-libsearch

---
Configure | 62 ++++++++++++++++++++++++++++++++++---------------------
1 file changed, 39 insertions(+), 23 deletions(-)
Configure | 24 ++++++++++++++++++++++++++++++++++---------------------
1 file changed, 15 insertions(+), 9 deletions(-)

diff --git a/Configure b/Configure
index bd96249..4febcd8 100755
Expand All @@ -19,7 +19,7 @@ index bd96249..4febcd8 100755
lib_ext=''
obj_ext=''
path_sep=''
@@ -5256,29 +5257,44 @@ done
@@ -5251,20 +5252,25 @@ done
for thislib in $libswanted; do
for thisdir in $libspath; do
xxx=''
Expand All @@ -32,20 +32,6 @@ index bd96249..4febcd8 100755
- $test -f "$xxx" && libstyle=shared
- fi
- if test ! -f "$xxx"; then
- xxx=$thisdir/lib$thislib.$so
- $test -f "$xxx" && eval $libscheck
- $test -f "$xxx" && libstyle=shared
- fi
- if test ! -f "$xxx"; then
- xxx=$thisdir/lib$thislib$_a
- $test -f "$xxx" && eval $libscheck
- $test -f "$xxx" && libstyle=static
- fi
- if test ! -f "$xxx"; then
- xxx=$thisdir/$thislib$_a
- $test -f "$xxx" && eval $libscheck
- $test -f "$xxx" && libstyle=static
- fi
+ if $test ! -f "$xxx" -a "X$ignore_versioned_solibs" = "X"; then
+ xxx=`ls $thisdir/lib$thislib.$so.[0-9] 2>/dev/null|sed -n '$p'`
+ $test -f "$xxx" && eval $libscheck
Expand All @@ -55,38 +41,19 @@ index bd96249..4febcd8 100755
+ $test -f "$xxx" && libstyle=shared
+ fi
+ if test ! -f "$xxx"; then
xxx=$thisdir/lib$thislib.$so$_a
$test -f "$xxx" && eval $libscheck
$test -f "$xxx" && libstyle="import"
fi
if test ! -f "$xxx"; then
+ xxx=$thisdir/lib$thislib.$so$_a
+ $test -f "$xxx" && eval $libscheck
+ $test -f "$xxx" && libstyle="import"
+ fi
+ if test ! -f "$xxx"; then
+ xxx=$thisdir/$thislib.$so$_a
+ $test -f "$xxx" && eval $libscheck
+ $test -f "$xxx" && libstyle="import"
+ fi
+ if test ! -f "$xxx"; then
+ xxx=$thisdir/lib$thislib.$so
+ $test -f "$xxx" && eval $libscheck
+ $test -f "$xxx" && libstyle=shared
+ fi
+ if test ! -f "$xxx"; then
+ xxx=$thisdir/$libprefix$thislib.$so
+ $test -f "$xxx" && eval $libscheck
+ $test -f "$xxx" && libstyle="system"
+ fi
+ if test ! -f "$xxx"; then
+ xxx=$thisdir/lib$thislib$_a
+ $test -f "$xxx" && eval $libscheck
+ $test -f "$xxx" && libstyle=static
+ fi
+ if test ! -f "$xxx"; then
+ xxx=$thisdir/$thislib$_a
+ $test -f "$xxx" && eval $libscheck
+ $test -f "$xxx" && libstyle=static
+ fi
if test ! -f "$xxx"; then
xxx=$thisdir/lib${thislib}_s$_a
$test -f "$xxx" && eval $libscheck
xxx=$thisdir/$thislib.$so$_a
$test -f "$xxx" && eval $libscheck
$test -f "$xxx" && libstyle="import"
--
2.37.1

8 changes: 4 additions & 4 deletions perl/0006-perl-5.36.0-msys2.patch
Original file line number Diff line number Diff line change
Expand Up @@ -1177,17 +1177,17 @@ index 203d86b..9246a21 100644
$p->{port_num} = $port2;

{
- local $TODO = "Believed not to work on $^O" if $^O =~ /^(?:hpux|MSWin32|os390|freebsd)$/;
+ local $TODO = "Believed not to work on $^O" if $^O =~ /^(?:hpux|MSWin32|msys|os390|freebsd)$/;
- local $TODO = "Believed not to work on $^O" if $^O =~ /^(?:MSWin32|os390)$/;
+ local $TODO = "Believed not to work on $^O" if $^O =~ /^(?:MSWin32|msys|os390)$/;
is($p->ping("127.0.0.1"), 1, 'second port is reachable');
}

@@ -133,7 +133,7 @@ SKIP: {

{
local $TODO = "Believed not to work on $^O"
- if $^O =~ /^(?:hpux|MSWin32|os390|freebsd)$/;
+ if $^O =~ /^(?:hpux|MSWin32|msys|os390|freebsd)$/;
- if $^O =~ /^(?:MSWin32|os390)$/;
+ if $^O =~ /^(?:MSWin32|msys|os390)$/;
is($p->ack(), '127.0.0.1', 'IP should be reachable');
}
}
Expand Down
12 changes: 6 additions & 6 deletions perl/PKGBUILD
Original file line number Diff line number Diff line change
Expand Up @@ -16,7 +16,7 @@ source=(https://www.cpan.org/src/5.0/perl-${pkgver}.tar.xz
perlbin.csh
perlbin.fish
perl-binary-module-dependency-1.template
0001-perl.cygwin-auto-image-base.patch
0001-fix-various-pods.patch
0002-perl.cygwin-hints.patch
0003-perl.cygwin-Configure-libsearch.patch
0004-perl.cygwin-Configure-libpth.patch
Expand Down Expand Up @@ -149,19 +149,19 @@ sha256sums=('eca551caec3bc549a4e590c0015003790bdd1a604ffe19cc78ee631d51f7072e'
'478a52dc440d5ca324f4c95238b39cc8c90d5d7d8d5601fa085ffef79fea04f4'
'11ce66bcf4803b0bf27179a32ce53f41bcdfa967c4c0d54ac103dbc4951d18a3'
'fe91f1de38af525cb82503feef553b71299c52ea52c01b1959143f48f4051ffa'
'b3bd02ed1d8a2ae160d9b16359f0c4a347e7990206ed972a41849abe695ca337'
'ba3259e3e82ee80820426fd407b5e3ddf01a6146d8309e2eabd5347221ab2ab3'
'48c58ecf9de7fbfe620504ed462bae4c855758dbd21f475d9d646bfa92c87aea'
'49f7122338500e1bc211766102eae959910d199f930bbcd47520dadae9b2c793'
'e45df328a7128604a1a7b901e44da67f7ebb34162ca23c980b4e36553c0e7449'
'a074ce00dabd7876293cf0fa8c8be26029992f51873e33cd2213b6acf60cafbb'
'1bf02b601f670cc1c8f65e63ec7a10578f92c8ecd8a5752fe331479bd6115311'
'e05e20b29c950555edfa246d2b9177188a4b265d1887c262f5b272f382696474'
'd8935f9a246ba112036d3081cf928f9539fcc5de777b678e83978877732f679f'
'3ec217cb7f47c34a79addb9396d522596495584aaf6b24b17c6caf6a16d2cb62'
'4c44801139321e77a3ade921ce93b114100346ad5b17d03a67b2a92b85ee8a27')

prepare() {
chmod -R 0666 ${srcdir}/${pkgname}-${pkgver}
cd ${srcdir}/${pkgname}-${pkgver}

patch -p1 -i ${srcdir}/0001-perl.cygwin-auto-image-base.patch
patch -p1 -i ${srcdir}/0001-fix-various-pods.patch
patch -p1 -i ${srcdir}/0002-perl.cygwin-hints.patch
patch -p1 -i ${srcdir}/0003-perl.cygwin-Configure-libsearch.patch
patch -p1 -i ${srcdir}/0004-perl.cygwin-Configure-libpth.patch
Expand Down

0 comments on commit 9ce7eca

Please sign in to comment.