Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Arista EOS: Inconsistent Results for VLAN - CLI vs Config #287

Open
jvanderaa opened this issue Nov 21, 2022 · 2 comments
Open

Arista EOS: Inconsistent Results for VLAN - CLI vs Config #287

jvanderaa opened this issue Nov 21, 2022 · 2 comments

Comments

@jvanderaa
Copy link
Contributor

Environment

  • Python version:
  • Network Importer version:

Steps to Reproduce

  1. Setup an Arista device
  2. Configure some VLAN interfaces and L2 VLANs
  3. Onboard the VLANs

Relevant Device Configuration

hostname dc1-spine01
!
spanning-tree mode mstp
!
no aaa root
!
username admin privilege 15 role network-admin secret sha512 $6$/2ahlpMNIqeutSHN$BaGxR5MONIE9q0lIlVYk.MaNdbye.dq4BDGPz.BuZs/9DXi3avfzdoWDENKawx0tXHr1urZrOLbjRRevbbwLX0
!
vlan 2000
   name TEST
!
vlan 2001
!
interface Ethernet1
!
interface Ethernet2
   switchport access vlan 2000
!
interface Ethernet3
   switchport access vlan 2001
!
interface Ethernet4
!
interface Ethernet5
!
interface Ethernet6
!
interface Ethernet7
!
interface Ethernet8
!
interface Ethernet9
!
interface Ethernet10
!
interface Ethernet11
!
interface Ethernet12
!
interface Management1
   ip address 198.51.100.4/26
!
interface Vlan2088
!
no ip routing
!
ip route 0.0.0.0/0 198.51.100.1
!
management api http-commands
   no shutdown
!
management api gnmi
   transport grpc default
!
end

Expected Behavior

Consistent Onboarding

Observed Behavior

CLI Onboarding

site
  site: msp
    vlan
      vlan: msp__2088 MISSING in Network
device
  device: dc1-spine01
    interface
      interface: Ethernet2
        access_vlan    Network(msp__2000)    Nautobot(None)
      interface: Ethernet3
        access_vlan    Network(msp__2001)    Nautobot(None)
2022-11-21 23:37:12,804 - network-importer - INFO - Execution finished, processed 1 device(s)

Config Onboarding

site
  site: msp
    vlan
      vlan: msp__2000 MISSING in Nautobot
      vlan: msp__2001 MISSING in Nautobot
device
  device: dc1-spine01
    interface
      interface: Ethernet2
        access_vlan    Network(msp__2000)    Nautobot(None)
      interface: Ethernet3
        access_vlan    Network(msp__2001)    Nautobot(None)
@jvanderaa
Copy link
Contributor Author

I believe that the config onboarding is the accurate one and CLI one is the one that needs to get updated. Likely caused by https://github.com/networktocode/network-importer/blob/develop/network_importer/drivers/arista_eos.py#L29

@jvanderaa
Copy link
Contributor Author

I just did a test run with NAPALM get_vlans getter. Everything is checking out fine there. So the link of the issue previously is not the culprit.

The real interesting thing that I'm looking at on this is that the site VLAN is different than the device interface VLAN assignment.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

No branches or pull requests

1 participant