An overlay of DOS tools for nix.
You can import these packages using the Nixpkgs overlay feature, by consulting the wiki page on Overlays. An example is provided below, which you may want to modify.
{ config, lib, pkgs, ...}:
let
dosOverlay = (import (builtins.fetchTarball "https://github.com/terinjokes/dos.nix/archive/master.tar.gz"));
in
{
nixpkgs.overlays = [ dosOverlay ];
environment.systemPackages = with pkgs; [ dosemu2 ];
# ...
}
This overlay provides the following packages:
Package | Description |
---|---|
comcom32 | 32-bit command interpreter for DOS |
dosemu2 | DOS Emulator for Linux |
djgpp | Cross-compiler targetting 32-bit DOS |
fdpp | A 64-bit DOS core |