Skip to content

Commit

Permalink
build: lower required cmake version to 3.16
Browse files Browse the repository at this point in the history
We are mainly developing for noetic, where the standard cmake version
from the official package repositories is 3.16.3.
CCache usage is now depending on whether cmake 3.18 or higher is used,
because it uses a call to cmake_language which is a new feature in 3.18.
  • Loading branch information
DavidPL1 committed Aug 4, 2023
1 parent 8487c26 commit bdd9a58
Show file tree
Hide file tree
Showing 2 changed files with 4 additions and 2 deletions.
2 changes: 1 addition & 1 deletion mujoco_ros/CMakeLists.txt
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
cmake_minimum_required(VERSION 3.17 FATAL_ERROR)
cmake_minimum_required(VERSION 3.16 FATAL_ERROR)
project(mujoco_ros VERSION 0.6.0 LANGUAGES CXX)

set(CMAKE_C_STANDARD 11)
Expand Down
4 changes: 3 additions & 1 deletion mujoco_ros/cmake/ProjectOption.cmake
Original file line number Diff line number Diff line change
Expand Up @@ -57,7 +57,9 @@ function(configure_project_option)
configure_project_setting()

configure_interprocedural_optimization(DISABLE_FOR_CONFIG ${IPO_DISABLE_FOR_CONFIG})
configure_compiler_cache(OPTION ${CCACHE_LAUNCHER} BASE_DIR ${CCACHE_CCACHE_BASE_DIR})
if(CMAKE_VERSION VERSION_GREATER_EQUAL "3.18")
configure_compiler_cache(OPTION ${CCACHE_LAUNCHER} BASE_DIR ${CCACHE_CCACHE_BASE_DIR})
endif()
configure_project_warnings(TARGET ${WARNING_TARGET} WARNINGS ${WARNING_PROJECT_WARNINGS})
configure_project_avx_support(TARGET ${AVX_TARGET})

Expand Down

0 comments on commit bdd9a58

Please sign in to comment.